summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-16 22:26:32 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-16 22:26:32 +0000
commit1f7c5d645f4d9da06aa5a8544b64e2bac8a8d8ee (patch)
treee7e4558190a108f192638c5c70fbd3441f8ccfe9 /sys-devel
parentRespect user LDFLAGS #209730 by Diego. (diff)
downloadgentoo-2-1f7c5d645f4d9da06aa5a8544b64e2bac8a8d8ee.tar.gz
gentoo-2-1f7c5d645f4d9da06aa5a8544b64e2bac8a8d8ee.tar.bz2
gentoo-2-1f7c5d645f4d9da06aa5a8544b64e2bac8a8d8ee.zip
Version bump #209123.
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog9
-rw-r--r--sys-devel/gcc/gcc-4.2.3.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 4e8cd95aae04..62197cd414c1 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.639 2007/12/29 18:18:51 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.640 2008/02/16 22:26:32 vapier Exp $
+
+*gcc-4.2.3 (16 Feb 2008)
+
+ 16 Feb 2008; Mike Frysinger <vapier@gentoo.org> +gcc-4.2.3.ebuild:
+ Version bump #209123.
29 Dec 2007; Mike Frysinger <vapier@gentoo.org> gcc-3.3.6-r1.ebuild:
Grab fixes from newer versions so we can build again #201035 Carlo Marcelo
diff --git a/sys-devel/gcc/gcc-4.2.3.ebuild b/sys-devel/gcc/gcc-4.2.3.ebuild
new file mode 100644
index 000000000000..180d8f510194
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.3.ebuild,v 1.1 2008/02/16 22:26:32 vapier Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
+ virtual/libiconv
+ fortran? (
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.2.0_p10
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
+}