summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-03 21:39:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-03 21:39:59 +0000
commit20fcb5506c04618c70194d8ee56015dd0eb6632d (patch)
tree489e16556019cec2c52f552dcd12dee12d8d71c5 /sys-devel
parentInitial add (Manifest recommit) (diff)
downloadgentoo-2-20fcb5506c04618c70194d8ee56015dd0eb6632d.tar.gz
gentoo-2-20fcb5506c04618c70194d8ee56015dd0eb6632d.tar.bz2
gentoo-2-20fcb5506c04618c70194d8ee56015dd0eb6632d.zip
Make sure GCC_CONFIG is taken only from the selected profile.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog8
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r4 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r3)0
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.73
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.3.7-r3.ebuild)2
4 files changed, 10 insertions, 3 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index c27439682095..934dda12e09d 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.66 2004/12/03 02:43:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.67 2004/12/03 21:39:59 vapier Exp $
+
+*gcc-config-1.3.7-r4 (03 Dec 2004)
+
+ 03 Dec 2004; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.7,
+ -gcc-config-1.3.7-r3.ebuild, +gcc-config-1.3.7-r4.ebuild:
+ Make sure GCC_CONFIG is taken only from the selected profile.
*gcc-config-1.3.7-r3 (02 Dec 2004)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r3 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r4
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r3
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.7-r4
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.7 b/sys-devel/gcc-config/files/gcc-config-1.3.7
index 11fa5d1cfb58..604fc92b3b32 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.7
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.7
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.7,v 1.6 2004/12/03 02:43:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.7,v 1.7 2004/12/03 21:39:59 vapier Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
trap ":" INT QUIT TSTP
@@ -162,6 +162,7 @@ switch_profile() {
fi
# Setup things properly again for this profile
+ unset GCC_CONFIG
source "${GCC_ENV_D}/${CC_COMP}"
OLD_CC_COMP=$(get_current_profile)
diff --git a/sys-devel/gcc-config/gcc-config-1.3.7-r3.ebuild b/sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild
index 13cec197e5e4..6b797473719c 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.7-r3.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.7-r3.ebuild,v 1.1 2004/12/03 02:43:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.7-r4.ebuild,v 1.1 2004/12/03 21:39:59 vapier Exp $
inherit toolchain-funcs