summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-07 22:37:15 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-07 22:37:15 +0000
commit26d1faed4038c4130531456afddca26f97710aad (patch)
tree92f290d1e3b31ecaa5c0f64996eabbdd9da2fed5 /sys-devel
parentold (diff)
downloadgentoo-2-26d1faed4038c4130531456afddca26f97710aad.tar.gz
gentoo-2-26d1faed4038c4130531456afddca26f97710aad.tar.bz2
gentoo-2-26d1faed4038c4130531456afddca26f97710aad.zip
Version bump #331549 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.4.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 90162faadc42..8248c4567a41 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.87 2010/05/24 13:53:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.88 2010/08/07 22:37:15 vapier Exp $
+
+*bison-2.4.3 (07 Aug 2010)
+
+ 07 Aug 2010; Mike Frysinger <vapier@gentoo.org> +bison-2.4.3.ebuild:
+ Version bump #331549 by Arfrever Frehtes Taifersar Arahesis.
24 May 2010; Raúl Porcel <armin76@gentoo.org> bison-2.4.1.ebuild:
alpha/arm/ia64/m68k/s390/sh/sparc stable wrt #311867
diff --git a/sys-devel/bison/bison-2.4.3.ebuild b/sys-devel/bison/bison-2.4.3.ebuild
new file mode 100644
index 000000000000..158635029677
--- /dev/null
+++ b/sys-devel/bison/bison-2.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.3.ebuild,v 1.1 2010/08/07 22:37:15 vapier Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="sys-devel/m4"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+ mv "${D}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib* || die
+
+ dodoc AUTHORS NEWS ChangeLog README OChangeLog THANKS TODO
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}