summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-04 18:36:29 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-04 18:36:29 +0000
commit5eb77c94a64261c4df32a2bec451fb6110c494d6 (patch)
treeb6980e9321049489625ab1f599c63406cc97cc8b /sys-devel
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #332527 (diff)
downloadgentoo-2-5eb77c94a64261c4df32a2bec451fb6110c494d6.tar.gz
gentoo-2-5eb77c94a64261c4df32a2bec451fb6110c494d6.tar.bz2
gentoo-2-5eb77c94a64261c4df32a2bec451fb6110c494d6.zip
Also fix libEnhancedDisassembly, which is only built on Darwin 10 (Mac OS X Snow Leopard)
(Portage version: 2.2.01.15553-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-2.7.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index d859e63f7157..16016d0f44de 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.17 2010/09/03 17:49:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.18 2010/09/04 18:36:29 grobian Exp $
+
+ 04 Sep 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.7.ebuild:
+ Also fix libEnhancedDisassembly, which is only built on Darwin 10 (Mac OS
+ X Snow Leopard)
03 Sep 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.7.ebuild:
Marked ~amd64-linux
diff --git a/sys-devel/llvm/llvm-2.7.ebuild b/sys-devel/llvm/llvm-2.7.ebuild
index 36112354298f..1bc0c201f84b 100644
--- a/sys-devel/llvm/llvm-2.7.ebuild
+++ b/sys-devel/llvm/llvm-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.6 2010/09/03 17:49:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.7 2010/09/04 18:36:29 grobian Exp $
EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -153,7 +153,9 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{LLVMHello,LTO,profile_rt}.dylib ; do
+ for lib in lib{EnhancedDisassembly,LLVMHello,LTO,profile_rt}.dylib ; do
+ # libEnhancedDisassembly is Darwin10 only
+ [[ -f ${ED}/usr/lib/${lib} ]] || continue
install_name_tool -id "${EPREFIX}"/usr/lib/${lib} \
"${ED}"/usr/lib/${lib}
done