summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-23 18:20:41 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-23 18:20:41 +0000
commit660e3c8598e48e9258a4ec40bd6603bec0687130 (patch)
treed63957dd7df50ca828a2532e22a60d59939da0ce /sys-devel
parentInitial ebuild by Marcin Mirosław, bug #436486 (diff)
downloadgentoo-2-660e3c8598e48e9258a4ec40bd6603bec0687130.tar.gz
gentoo-2-660e3c8598e48e9258a4ec40bd6603bec0687130.tar.bz2
gentoo-2-660e3c8598e48e9258a4ec40bd6603bec0687130.zip
Fix the hack for subversion.eclass bug #282486.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999-r1.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index a0bcd1f61184..fec4b4bd03b5 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.118 2013/07/22 12:01:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.119 2013/07/23 18:20:41 mgorny Exp $
+
+ 23 Jul 2013; Michał Górny <mgorny@gentoo.org> llvm-9999-r1.ebuild:
+ Fix the hack for subversion.eclass bug #282486.
22 Jul 2013; Michał Górny <mgorny@gentoo.org>
+files/llvm-3.3-insecure-rpath.patch:
diff --git a/sys-devel/llvm/llvm-9999-r1.ebuild b/sys-devel/llvm/llvm-9999-r1.ebuild
index 216e37bb223d..99b971147b16 100644
--- a/sys-devel/llvm/llvm-9999-r1.ebuild
+++ b/sys-devel/llvm/llvm-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999-r1.ebuild,v 1.1 2013/07/21 10:00:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999-r1.ebuild,v 1.2 2013/07/23 18:20:41 mgorny Exp $
EAPI=5
@@ -87,7 +87,7 @@ src_unpack() {
# Force version match between LLVM, compiler-rt & clang
# but first work-around subversion.eclass smartness, bug #282486.
- subversion_wc_info "http://llvm.org/svn/llvm-project/compiler-rt/trunk"
+ ESVN_PROJECT=compiler-rt subversion_wc_info "http://llvm.org/svn/llvm-project/compiler-rt/trunk"
local ESVN_REVISION=${ESVN_WC_REVISION}
ESVN_PROJECT=clang S="${S}"/tools/clang subversion_fetch "http://llvm.org/svn/llvm-project/cfe/trunk"