summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-24 04:33:46 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-24 04:33:46 +0000
commit7a68c808b73b92ee08eecc493c6ffdb80bb655fb (patch)
treedc72211be4b7bf94d73e2a950ce87b848223cf77 /sys-devel
parentpunt get_number_of_jobs (diff)
downloadgentoo-2-7a68c808b73b92ee08eecc493c6ffdb80bb655fb.tar.gz
gentoo-2-7a68c808b73b92ee08eecc493c6ffdb80bb655fb.tar.bz2
gentoo-2-7a68c808b73b92ee08eecc493c6ffdb80bb655fb.zip
Version bumpage.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog14
-rw-r--r--sys-devel/gcc/files/3.4.4/gcc-3.4.4-cross-compile.patch59
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.3.65
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.4.45
-rw-r--r--sys-devel/gcc/gcc-3.3.6.ebuild90
-rw-r--r--sys-devel/gcc/gcc-3.4.4.ebuild137
6 files changed, 309 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 249172e7f79e..98e471f920a9 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.408 2005/05/22 03:40:17 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.409 2005/05/24 04:33:46 vapier Exp $
+
+*gcc-3.4.4 (24 May 2005)
+
+ 24 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/3.4.4/gcc-3.4.4-cross-compile.patch, +gcc-3.4.4.ebuild:
+ Version bumpage.
+
+*gcc-3.3.6 (24 May 2005)
+
+ 24 May 2005; Mike Frysinger <vapier@gentoo.org>
+ +gcc-3.3.6.ebuild:
+ Version bumpage.
*gcc-4.0.1_beta20050521 (22 May 2005)
diff --git a/sys-devel/gcc/files/3.4.4/gcc-3.4.4-cross-compile.patch b/sys-devel/gcc/files/3.4.4/gcc-3.4.4-cross-compile.patch
new file mode 100644
index 000000000000..b9116996fc52
--- /dev/null
+++ b/sys-devel/gcc/files/3.4.4/gcc-3.4.4-cross-compile.patch
@@ -0,0 +1,59 @@
+--- gcc/config/sh/linux.h
++++ gcc/config/sh/linux.h
+@@ -145,6 +145,7 @@
+ /* Do code reading to identify a signal frame, and set the frame
+ state data appropriately. See unwind-dw2.c for the structs. */
+
++#ifndef inhibit_libc
+ #ifdef IN_LIBGCC2
+ #include <signal.h>
+ #include <sys/ucontext.h>
+@@ -295,6 +296,7 @@
+
+ #endif /* defined (__SH5__) */
+ #endif /* IN_LIBGCC2 */
++#endif /* inhibit_libc */
+
+ /* For SH3 and SH4, we use a slot of the unwind frame which correspond
+ to a fake register number 16 as a placeholder for the return address
+--- gcc/config/i386/linux.h
++++ gcc/config/i386/linux.h
+@@ -208,6 +208,7 @@
+ /* Do code reading to identify a signal frame, and set the frame
+ state data appropriately. See unwind-dw2.c for the structs. */
+
++#ifndef inhibit_libc
+ #ifdef IN_LIBGCC2
+ /* There's no sys/ucontext.h for some (all?) libc1, so no
+ signal-turned-exceptions for them. There's also no configure-run for
+@@ -272,3 +273,4 @@
+ } while (0)
+ #endif /* not USE_GNULIBC_1 */
+ #endif /* IN_LIBGCC2 */
++#endif /* inhibit_libc */
+--- gcc/config/alpha/linux.h
++++ gcc/config/alpha/linux.h
+@@ -73,6 +73,7 @@
+ /* Do code reading to identify a signal frame, and set the frame
+ state data appropriately. See unwind-dw2.c for the structs. */
+
++#ifndef inhibit_libc
+ #ifdef IN_LIBGCC2
+ #include <signal.h>
+ #include <sys/ucontext.h>
+@@ -122,3 +123,4 @@
+ (FS)->retaddr_column = 64; \
+ goto SUCCESS; \
+ } while (0)
++#endif /* inhibit_libc */
+--- gcc/config.gcc
++++ gcc/config.gcc
+@@ -321,7 +321,7 @@
+ need_64bit_hwint=yes
+ ;;
+ # Note the 'l'; we need to be able to match e.g. "shle" or "shl".
+-sh[123456789l]*-*-*)
++sh[123456789lbe]*-*-*)
+ cpu_type=sh
+ need_64bit_hwint=yes
+ ;;
diff --git a/sys-devel/gcc/files/digest-gcc-3.3.6 b/sys-devel/gcc/files/digest-gcc-3.3.6
new file mode 100644
index 000000000000..d69e2fb115fc
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-3.3.6
@@ -0,0 +1,5 @@
+MD5 6936616a967da5a0b46f1e7424a06414 gcc-3.3.6.tar.bz2 23972413
+MD5 497f48d37cceae248f73289904b00b3e gcc-3.3.6-uclibc-patches-1.0.tar.bz2 28882
+MD5 ee2d6fa08938e54f45ffddb766b35646 gcc-3.3.6-patches-1.0.tar.bz2 43769
+MD5 21d3630720af45934849c70f8ac9258a gcc-3.3.6-piepatches-v8.7.8.tar.bz2 27532
+MD5 44dcd5ed339c1d01fd1d8629ba36f7fb bounds-checking-gcc-3.3.6-1.00-r1.patch.bz2 829063
diff --git a/sys-devel/gcc/files/digest-gcc-3.4.4 b/sys-devel/gcc/files/digest-gcc-3.4.4
new file mode 100644
index 000000000000..4f846a5f1968
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-3.4.4
@@ -0,0 +1,5 @@
+MD5 b594ff4ea4fbef4ba9220887de713dfe gcc-3.4.4.tar.bz2 27565872
+MD5 2e82451a5de7e7be5ee0e15ed2648aff gcc-3.4.4-uclibc-patches-1.0.tar.bz2 21617
+MD5 e37ead9b62ab7fd2fafb6559e943221a gcc-3.4.4-patches-1.0.tar.bz2 83993
+MD5 474718bd45586247a7937bed549d8562 gcc-3.4.4-piepatches-v8.7.8.tar.bz2 15514
+MD5 e718fd89d6323e00f6f684ff2218511d bounds-checking-gcc-3.4.4_pre-1.00.patch.bz2 814694
diff --git a/sys-devel/gcc/gcc-3.3.6.ebuild b/sys-devel/gcc/gcc-3.3.6.ebuild
new file mode 100644
index 000000000000..832dae0f1abb
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.3.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.1 2005/05/24 04:33:46 vapier Exp $
+
+MAN_VER=""
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+PIE_VER="8.7.8"
+PP_VER=""
+PP_FVER=""
+HTB_VER="1.00-r1"
+
+ETYPE="gcc-compiler"
+
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+SSP_STABLE="x86 sparc amd64"
+SSP_UCLIBC_STABLE="arm mips ppc x86"
+PIE_GLIBC_STABLE="x86 sparc amd64"
+PIE_UCLIBC_STABLE="x86 mips ppc"
+
+# arch/libc configurations known to be broken with {PIE,SSP}-by-default
+SSP_UNSUPPORTED="hppa"
+SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
+PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
+PIE_GLIBC_UNSUPPORTED="hppa"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=${SPLIT_SPECS-true}
+
+#GENTOO_PATCH_EXCLUDE=""
+#PIEPATCH_EXCLUDE=""
+
+inherit toolchain eutils
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+KEYWORDS="-*"
+
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND=">=sys-devel/gcc-config-1.3.10
+ >=sys-libs/zlib-1.1.4
+ !sys-devel/hardened-gcc
+ !uclibc? ( >=sys-libs/glibc-2.3.2-r9 )
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875
+ amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
+ sparc? ( hardened? ( >=sys-libs/glibc-2.3.3.20040420 ) )
+ !build? (
+ gcj? (
+ gtk? ( >=x11-libs/gtk+-2.2 )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+
+if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
+ RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
+fi
+
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+PDEPEND="sys-devel/gcc-config"
+
+src_unpack() {
+ gcc_src_unpack
+
+ if [[ -n ${UCLIBC_VER} ]] && is_uclibc ; then
+ mv ${S}/gcc-3.3.2/libstdc++-v3/config/os/uclibc ${S}/libstdc++-v3/config/os/ || die
+ mv ${S}/gcc-3.3.2/libstdc++-v3/config/locale/uclibc ${S}/libstdc++-v3/config/locale/ || die
+ fi
+
+ # misc patches that havent made it into a patch tarball yet
+ epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if ! use build && use objc && ! use gcj ; then
+ epatch ${FILESDIR}/3.3.4/libffi-without-libgcj.patch
+ #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+
+ [[ $(tc-arch) == "amd64" ]] && \
+ replace-cpu-flags k8 athlon64 opteron i686
+}
diff --git a/sys-devel/gcc/gcc-3.4.4.ebuild b/sys-devel/gcc/gcc-3.4.4.ebuild
new file mode 100644
index 000000000000..1b2921e6f69c
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.4.4.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.1 2005/05/24 04:33:46 vapier Exp $
+
+MAN_VER=""
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+PIE_VER="8.7.8"
+PP_VER=""
+PP_FVER=""
+HTB_VER="1.00"
+HTB_GCC_VER="3.4.4_pre"
+
+GCC_LIBSSP_SUPPORT="true"
+
+ETYPE="gcc-compiler"
+
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+SSP_STABLE="x86 sparc amd64 ppc ppc64"
+SSP_UCLIBC_STABLE="arm mips ppc x86"
+PIE_GLIBC_STABLE="x86 sparc amd64 ppc ppc64"
+PIE_UCLIBC_STABLE="x86 mips ppc"
+
+# arch/libc configurations known to be broken with {PIE,SSP}-by-default
+SSP_UNSUPPORTED="hppa"
+SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
+PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
+PIE_GLIBC_UNSUPPORTED="hppa"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=${SPLIT_SPECS-true}
+
+#GENTOO_PATCH_EXCLUDE=""
+#PIEPATCH_EXCLUDE=""
+
+inherit toolchain eutils
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+KEYWORDS="-*"
+
+# we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND=">=sys-devel/gcc-config-1.3.10
+ >=sys-libs/zlib-1.1.4
+ !sys-devel/hardened-gcc
+ elibc_glibc? (
+ >=sys-libs/glibc-2.3.3_pre20040420-r1
+ hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
+ )
+ multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 )
+ !build? (
+ gcj? (
+ gtk? ( >=x11-libs/gtk+-2.2 )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+
+if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
+ RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
+fi
+
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=sys-devel/binutils-2.14.90.0.8-r1
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+PDEPEND="sys-devel/gcc-config"
+
+src_unpack() {
+ gcc_src_unpack
+
+ # misc patches that havent made it into a patch tarball yet
+ epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ # nothing in the tree provides libssp.so, so nothing will ever trigger this
+ # logic, but having the patch in the tree makes life so much easier for me
+ # since I dont have to also have an overlay for this.
+ want_libssp && epatch "${FILESDIR}"/3.4.3/libssp.patch
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if ! use build && use objc && ! use gcj ; then
+ epatch "${FILESDIR}"/3.4.3/libffi-without-libgcj.patch
+ #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+
+ # hack around some ugly 32bit sse2 wrong-code bugs
+ epatch "${FILESDIR}"/3.4.2/gcc34-m32-no-sse2.patch
+ epatch "${FILESDIR}"/3.4.2/gcc34-fix-sse2_pinsrw.patch
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
+
+ # Arch stuff
+ case $(tc-arch) in
+ mips)
+ # If mips, and we DON'T want multilib, then rig gcc to only use n32 OR n64
+ if ! is_multilib; then
+ use n32 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n32only.patch
+ use n64 && epatch ${FILESDIR}/3.4.1/gcc-3.4.1-mips-n64only.patch
+ fi
+
+ # Patch forward-ported from a gcc-3.0.x patch that adds -march=r10000 and
+ # -mtune=r10000 support to gcc (Allows the compiler to generate code to
+ # take advantage of R10k's second ALU, perform shifts, etc..
+ #
+ # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? :)
+ epatch ${FILESDIR}/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
+
+ # This is a very special patch -- it allows us to build semi-usable kernels
+ # on SGI IP28 (Indigo2 Impact R10000) systems. The patch is henceforth
+ # regarded as a kludge by upstream, and thus, it will never get accepted upstream,
+ # but for our purposes of building a kernel, it works.
+ # Unless you're building an IP28 kernel, you really don't need care about what
+ # this patch does, because if you are, you are probably already aware of what
+ # it does.
+ # All that said, the abilities of this patch are disabled by default and need
+ # to be enabled by passing -mip28-cache-barrier. Only used to build kernels,
+ # There is the possibility it may be used for very specific userland apps too.
+ if use ip28; then
+ epatch ${FILESDIR}/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v2.patch
+ fi
+ ;;
+ amd64)
+ if is_multilib ; then
+ sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' libstdc++-v3/configure || die
+ fi
+ ;;
+ esac
+}