summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-05 08:10:59 +0000
committerMike Frysinger <vapier@gentoo.org>2015-08-05 08:10:59 +0000
commit7a8e1c077b2d168cf93c4acbd5fc4c2850a1aad0 (patch)
treee64d0f7b3ffc244cf9f86cb985d8ca7bf5d5c1a0 /sys-devel
parentMark arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-7a8e1c077b2d168cf93c4acbd5fc4c2850a1aad0.tar.gz
gentoo-2-7a8e1c077b2d168cf93c4acbd5fc4c2850a1aad0.tar.bz2
gentoo-2-7a8e1c077b2d168cf93c4acbd5fc4c2850a1aad0.zip
Include fix from git for test output #547586.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog6
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.8-dont_source_functions_sh_from_etc_initd.patch33
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 217562ec34d2..d82de67c453c 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.231 2015/04/25 16:38:01 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.232 2015/08/05 08:10:59 vapier Exp $
+
+ 05 Aug 2015; Mike Frysinger <vapier@gentoo.org>
+ files/gcc-config-1.8-dont_source_functions_sh_from_etc_initd.patch:
+ Include fix from git for test output #547586.
25 Apr 2015; Mike Gilbert <floppym@gentoo.org> gcc-config-1.6.ebuild,
gcc-config-1.7.1.ebuild, gcc-config-1.7.2.ebuild, gcc-config-1.7.ebuild:
diff --git a/sys-devel/gcc-config/files/gcc-config-1.8-dont_source_functions_sh_from_etc_initd.patch b/sys-devel/gcc-config/files/gcc-config-1.8-dont_source_functions_sh_from_etc_initd.patch
index 878ca7e25555..a4b7de2ffc54 100644
--- a/sys-devel/gcc-config/files/gcc-config-1.8-dont_source_functions_sh_from_etc_initd.patch
+++ b/sys-devel/gcc-config/files/gcc-config-1.8-dont_source_functions_sh_from_etc_initd.patch
@@ -12,3 +12,36 @@
exit 1
}
esyslog() { :; }
+
+From d45de09450ffb63b138bbb7f78cae43e1101e2ec Mon Sep 17 00:00:00 2001
+From: Ryan Hill <rhill@gentoo.org>
+Date: Tue, 12 May 2015 22:09:28 -0600
+Subject: [PATCH] Ignore whitespace when diffing test results.
+
+The amount of whitespace output by ebegin/eend from gentoo-functions
+is dynamic (seems to be dependent on terminal width). Since we can't
+predict this we have to ignore all whitespace differences.
+
+URL: https://bugs.gentoo.org/547586
+Reported-by: tka <tka@kamph.org>
+Signed-off-by: Ryan Hill <rhill@gentoo.org>
+---
+ tests/run_tests | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/run_tests b/tests/run_tests
+index 2ff7d77..397d667 100755
+--- a/tests/run_tests
++++ b/tests/run_tests
+@@ -44,7 +44,7 @@ cmp_log() {
+ args+=( -e "s|: line [0-9]*: |: |g" )
+ sed "${args[@]}" "${exp}" > "${exp}.tmp"
+ sed "${args[@]}" "${log}" > "${log}.tmp"
+- diff -u "${exp}.tmp" "${log}.tmp" > "${log}.diff"
++ diff -uw "${exp}.tmp" "${log}.tmp" > "${log}.diff"
+ ret=$?
+ rm "${exp}.tmp"
+ return ${ret}
+--
+2.4.4
+