summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-06-17 09:54:37 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-06-17 09:54:37 +0000
commit878e7a65edd0dc8db991fc3eb583b081fafbfa33 (patch)
treec7e47cddfd5560bb637eb7d8543fcf09378bd26b /sys-devel
parentAdded to ~ppc (diff)
downloadgentoo-2-878e7a65edd0dc8db991fc3eb583b081fafbfa33.tar.gz
gentoo-2-878e7a65edd0dc8db991fc3eb583b081fafbfa33.tar.bz2
gentoo-2-878e7a65edd0dc8db991fc3eb583b081fafbfa33.zip
Fixed BUG #63699 by adding LIPERL=${LIBPERL} to emake command line.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog6
-rw-r--r--sys-devel/libperl/libperl-5.8.5.ebuild4
-rw-r--r--sys-devel/libperl/libperl-5.8.6.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index ca5abfe03886..89951ed42c42 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.61 2005/05/30 02:44:56 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.62 2005/06/17 09:54:37 kugelfang Exp $
+
+ 17 Jun 2005; Danny van Dyk <kugelfang@gentoo.org> libperl-5.8.5.ebuild,
+ libperl-5.8.6.ebuild:
+ Specifying LIBPERL variable for make on command line to fix BUG #63699.
29 May 2005; <solar@gentoo.org> libperl-5.8.2-r1.ebuild,
libperl-5.8.4-r1.ebuild, libperl-5.8.5-r1.ebuild, libperl-5.8.5.ebuild,
diff --git a/sys-devel/libperl/libperl-5.8.5.ebuild b/sys-devel/libperl/libperl-5.8.5.ebuild
index 914ea2f05a0d..78357dc7cd6b 100644
--- a/sys-devel/libperl/libperl-5.8.5.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.16 2005/05/30 02:44:56 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.17 2005/06/17 09:54:37 kugelfang Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -215,7 +215,7 @@ src_compile() {
${myconf} || die
emake -j1 -f Makefile depend || die "Couldn't make libperl.so depends"
- emake -j1 -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
+ emake -j1 -f Makefile LIBPERL=${LIBPERL} ${LIBPERL} || die "Unable to make libperl.so"
mv ${LIBPERL} ${WORKDIR}
}
diff --git a/sys-devel/libperl/libperl-5.8.6.ebuild b/sys-devel/libperl/libperl-5.8.6.ebuild
index d16131f08f89..993787ec53af 100644
--- a/sys-devel/libperl/libperl-5.8.6.ebuild
+++ b/sys-devel/libperl/libperl-5.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.10 2005/05/30 02:44:56 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.11 2005/06/17 09:54:37 kugelfang Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -217,7 +217,7 @@ src_compile() {
${myconf} || die
emake -j1 -f Makefile depend || die "Couldn't make libperl.so depends"
- emake -j1 -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
+ emake -j1 -f Makefile LIBPERL=${LIBPERL} ${LIBPERL} || die "Unable to make libperl.so"
mv ${LIBPERL} ${WORKDIR}
}