summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-17 02:19:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-17 02:19:41 +0000
commitaf4259aac5a60f7f658884361671f0d9bd7d0ed9 (patch)
tree90ebd83be366960e13b87a526b2b43d35119690c /sys-devel
parentinstall the rescue shell as "bb" and disable extraneous utils (diff)
downloadgentoo-2-af4259aac5a60f7f658884361671f0d9bd7d0ed9.tar.gz
gentoo-2-af4259aac5a60f7f658884361671f0d9bd7d0ed9.tar.bz2
gentoo-2-af4259aac5a60f7f658884361671f0d9bd7d0ed9.zip
old
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.6-r8.ebuild9
-rw-r--r--sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild178
-rw-r--r--sys-devel/binutils/binutils-2.15.97.ebuild10
-rw-r--r--sys-devel/binutils/binutils-2.16.90.0.1.ebuild10
-rw-r--r--sys-devel/binutils/binutils-2.16.90.0.2.ebuild11
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.14.90.0.6-r83
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.92.0.2-r13
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.973
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.16.90.0.13
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.16.90.0.23
10 files changed, 0 insertions, 233 deletions
diff --git a/sys-devel/binutils/binutils-2.14.90.0.6-r8.ebuild b/sys-devel/binutils/binutils-2.14.90.0.6-r8.ebuild
deleted file mode 100644
index 44aa13cbd158..000000000000
--- a/sys-devel/binutils/binutils-2.14.90.0.6-r8.ebuild
+++ /dev/null
@@ -1,9 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.6-r8.ebuild,v 1.4 2005/04/17 07:37:34 vapier Exp $
-
-PATCHVER="1.0"
-UCLIBC_PATCHVER="1.0"
-inherit toolchain-binutils
-
-KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 mips ~ppc ~sparc x86"
diff --git a/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild b/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild
deleted file mode 100644
index d586c1c921be..000000000000
--- a/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild,v 1.28 2005/05/10 18:42:00 pylon Exp $
-
-inherit eutils libtool flag-o-matic gnuconfig
-
-PATCHVER="1.2"
-UCLIBC_PATCHVER="1.0"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- mirror://gentoo/${PN}-${PV:0:4}-uclibc-patches-${UCLIBC_PATCHVER}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* amd64 -arm hppa -ia64 sparc x86 -ppc"
-IUSE="nls bootstrap build multitarget uclibc"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- mkdir -p ${WORKDIR}/patch/skip
- mv ${WORKDIR}/patch/*no_rel_ro* ${WORKDIR}/patch/20_* ${WORKDIR}/patch/*ldsoconf* ${WORKDIR}/patch/skip/
-
- epatch ${WORKDIR}/patch
- epatch ${WORKDIR}/uclibc-patches
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-
- gnuconfig_update
-}
-
-src_compile() {
- strip-linguas -i */po #42033
-
- # Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa
- # Filter CFLAGS=".. -O2 .." on arm
- use arm && replace-flags -O? -O
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
- strip-flags && replace-flags -O3 -O2
-
- local myconf=
- [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage --no-uclibc
-
- ./configure \
- --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} \
- || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" all || die
-
- if ! use build
- then
- if ! use bootstrap
- then
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- # Make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- make DESTDIR=${D} \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- # c++filt is included with gcc -- what are these GNU people thinking?
- # but not the manpage, so leave that!
-# We install it now, as gcc-3.3 do not have it any longer ...
-# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- if [ -n "${PROFILE_ARCH}" ] &&
- [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]; then
- dosym ${CHOST} /usr/${CHOST/-/64-}
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
-
- cd ${S}
- if ! use build
- then
- make DESTDIR=${D} install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-
- use uclibc && rm -rf ${D}/usr/lib/ldscripts
-
- # remove shared libs' links (.so) to build all apps against the static versions
- use uclibc && rm -f ${D}/usr/lib/lib{bfd,opcodes}.so ${D}/usr/lib/lib*.la
-}
diff --git a/sys-devel/binutils/binutils-2.15.97.ebuild b/sys-devel/binutils/binutils-2.15.97.ebuild
deleted file mode 100644
index 0e81a17357d9..000000000000
--- a/sys-devel/binutils/binutils-2.15.97.ebuild
+++ /dev/null
@@ -1,10 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.97.ebuild,v 1.3 2005/05/06 02:29:55 vapier Exp $
-
-PATCHVER="1.0"
-UCLIBC_PATCHVER="1.0"
-inherit toolchain-binutils
-
-# not supported, please dont keyword, use 2.16
-KEYWORDS="-*"
diff --git a/sys-devel/binutils/binutils-2.16.90.0.1.ebuild b/sys-devel/binutils/binutils-2.16.90.0.1.ebuild
deleted file mode 100644
index 506b6f2f4b44..000000000000
--- a/sys-devel/binutils/binutils-2.16.90.0.1.ebuild
+++ /dev/null
@@ -1,10 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.16.90.0.1.ebuild,v 1.4 2005/05/06 02:29:55 vapier Exp $
-
-PATCHVER="1.0"
-UCLIBC_PATCHVER="1.0"
-inherit toolchain-binutils
-
-# not supported, please dont keyword, use 2.16.90.0.2
-KEYWORDS="-*"
diff --git a/sys-devel/binutils/binutils-2.16.90.0.2.ebuild b/sys-devel/binutils/binutils-2.16.90.0.2.ebuild
deleted file mode 100644
index 747d15bccc7d..000000000000
--- a/sys-devel/binutils/binutils-2.16.90.0.2.ebuild
+++ /dev/null
@@ -1,11 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.16.90.0.2.ebuild,v 1.2 2005/05/06 02:33:47 vapier Exp $
-
-PATCHVER="1.1"
-UCLIBC_PATCHVER="1.0"
-inherit toolchain-binutils
-
-# ARCH - packages to test before marking
-# ia64 - elilo
-KEYWORDS="-*"
diff --git a/sys-devel/binutils/files/digest-binutils-2.14.90.0.6-r8 b/sys-devel/binutils/files/digest-binutils-2.14.90.0.6-r8
deleted file mode 100644
index f9ff156e16b8..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.14.90.0.6-r8
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 71b99dba3045a359dc314dbebedcf502 binutils-2.14.90.0.6.tar.bz2 10399066
-MD5 0b2c6cabe1d45dddacfab351d7a44d86 binutils-2.14.90.0.6-patches-1.0.tar.bz2 38048
-MD5 5c7006c632491a8ded240766767edbfd binutils-2.14.90.0.6-uclibc-patches-1.0.tar.bz2 6346
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.92.0.2-r1 b/sys-devel/binutils/files/digest-binutils-2.15.92.0.2-r1
deleted file mode 100644
index 93074c242fcc..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.15.92.0.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 702bc82d8b10914e112fb5c5d8b66498 binutils-2.15.92.0.2.tar.bz2 11019727
-MD5 d7c24c3391171278d90f1bdb4be2e673 binutils-2.15-uclibc-patches-1.0.tar.bz2 5729
-MD5 61ba79391117a3745e2c3dfdee5d1d8d binutils-2.15.92.0.2-patches-1.2.tar.bz2 58678
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.97 b/sys-devel/binutils/files/digest-binutils-2.15.97
deleted file mode 100644
index cca23d70d42f..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.15.97
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 30632fdadbb3917844f7d2f0e3a4673e binutils-2.15.97.tar.bz2 12513767
-MD5 0f2172b4ce71af89345c75c29f38c745 binutils-2.15.97-patches-1.0.tar.bz2 21829
-MD5 040a7f92063dc11d80b53f7cf1b0a80f binutils-2.15.97-uclibc-patches-1.0.tar.bz2 6996
diff --git a/sys-devel/binutils/files/digest-binutils-2.16.90.0.1 b/sys-devel/binutils/files/digest-binutils-2.16.90.0.1
deleted file mode 100644
index 836be784c18f..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.16.90.0.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 b231856d84a6181572b0b3371cfc6843 binutils-2.16.90.0.1.tar.bz2 11424682
-MD5 92c46e5b9eb9890ad8cbf84545760ccc binutils-2.16.90.0.1-patches-1.0.tar.bz2 22133
-MD5 a6c4a989e809cd02105d93cabc1668a8 binutils-2.16.90.0.1-uclibc-patches-1.0.tar.bz2 2615
diff --git a/sys-devel/binutils/files/digest-binutils-2.16.90.0.2 b/sys-devel/binutils/files/digest-binutils-2.16.90.0.2
deleted file mode 100644
index 141e7b5c9c13..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.16.90.0.2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4c03bb2c97fb06ecd5e8e8dbb44a1878 binutils-2.16.90.0.2.tar.bz2 11476758
-MD5 2d1f1a44330f666d1c4cfe131dbc0699 binutils-2.16.90.0.2-patches-1.1.tar.bz2 25788
-MD5 3b3b2d7d01efddfc114de4b753686638 binutils-2.16.90.0.2-uclibc-patches-1.0.tar.bz2 2675