summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 14:28:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 14:28:40 +0000
commitb0b683a41cf51ede43bb35266a4eb3cbc61419f6 (patch)
tree218c69051b9a57e63e45215abd6aa9630ce1bd40 /sys-devel
parentmigrate to multilib, bug #479282 (diff)
downloadgentoo-2-b0b683a41cf51ede43bb35266a4eb3cbc61419f6.tar.gz
gentoo-2-b0b683a41cf51ede43bb35266a4eb3cbc61419f6.tar.bz2
gentoo-2-b0b683a41cf51ede43bb35266a4eb3cbc61419f6.zip
version bump
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/pmake/ChangeLog9
-rw-r--r--sys-devel/pmake/pmake-1.111.3.3.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
index 9f90f4d14ff5..06fb4734b6a7 100644
--- a/sys-devel/pmake/ChangeLog
+++ b/sys-devel/pmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/pmake
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.46 2012/09/11 01:30:35 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.47 2013/08/10 14:28:40 aballier Exp $
+
+*pmake-1.111.3.3 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +pmake-1.111.3.3.ebuild:
+ version bump
11 Sep 2012; Christoph Junghans <ottxor@gentoo.org> pmake-1.111.3.1.ebuild:
add prefix support (bug #434530)
diff --git a/sys-devel/pmake/pmake-1.111.3.3.ebuild b/sys-devel/pmake/pmake-1.111.3.3.ebuild
new file mode 100644
index 000000000000..918bd0a33e3a
--- /dev/null
+++ b/sys-devel/pmake/pmake-1.111.3.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.3.3.ebuild,v 1.1 2013/08/10 14:28:40 aballier Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs versionator
+
+MY_P="${PN}-$(get_version_component_range 1-2)"
+DEBIAN_SOURCE="${PN}_$(get_version_component_range 1-2).orig.tar.gz"
+DEBIAN_PATCH="${PN}_$(replace_version_separator 2 '-').debian.tar.gz"
+
+DESCRIPTION="BSD build tool to create programs in parallel. Debian's version of NetBSD's make"
+HOMEPAGE="http://www.netbsd.org/"
+SRC_URI="mirror://debian/pool/main/p/pmake/${DEBIAN_SOURCE}
+ mirror://debian/pool/main/p/pmake/${DEBIAN_PATCH}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ EPATCH_FORCE="yes" \
+ EPATCH_OPTS="-g0 -E --no-backup-if-mismatch -p1" \
+ EPATCH_SUFFIX="diff" \
+ epatch "${WORKDIR}/debian/patches"
+
+ # pmake makes the assumption that . and .. are the first two
+ # entries in a directory, which doesn't always appear to be the
+ # case on ext3... (05 Apr 2004 agriffis)
+ epatch "${FILESDIR}/${PN}-1.98-skipdots.patch"
+
+ # Don't ignore ldflags
+ epatch "${FILESDIR}/${PN}-1.111.1-ldflags.patch"
+}
+
+src_compile() {
+ # The following CFLAGS are almost directly from Red Hat 8.0 and
+ # debian/rules, so assume it's okay to void out the __COPYRIGHT
+ # and __RCSID. I've checked the source and don't see the point,
+ # but whatever... (07 Feb 2004 agriffis)
+ CFLAGS="${CFLAGS} -Wall -Wno-unused -D_GNU_SOURCE \
+ -DHAVE_STRERROR -DHAVE_STRDUP -DHAVE_SETENV \
+ -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
+ -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"$(tc-arch-kernel)\\\" \
+ -D_PATH_DEFSHELLDIR=\\\"${EPREFIX}/bin\\\" \
+ -D_PATH_DEFSYSPATH=\\\"${EPREFIX}/usr/share/mk\\\" \
+ -DHAVE_VSNPRINTF"
+ if [[ "${USERLAND}" == "GNU" ]]; then
+ CFLAGS="${CFLAGS} -D_PATH_DEFSYSPATH=\\\"${EPREFIX}/usr/share/mk/${PN}\\\""
+ fi
+
+ emake -f Makefile.boot \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ # Don't install these on BSD, else they conflict
+ if [[ "${USERLAND}" == "GNU" ]]; then
+ insinto /usr/share/mk/${PN}
+ doins mk/*
+ fi
+
+ newbin bmake pmake
+ dobin mkdep
+ mv make.1 pmake.1
+ doman mkdep.1 pmake.1
+ dodoc PSD.doc/tutorial.ms
+
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ dosym pmake /usr/bin/make
+ dosym pmake.1.gz /usr/share/man/man1/make.1.gz
+ fi
+}