summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-04-01 22:16:26 +0000
committerZack Welch <zwelch@gentoo.org>2003-04-01 22:16:26 +0000
commitcf012295e7e68515d56479ca383010fe61f7ee6e (patch)
tree274eb0bbce1f20683874f7e91fd24c8fa866fcce /sys-devel
parentfixing bug 1446 (diff)
downloadgentoo-2-cf012295e7e68515d56479ca383010fe61f7ee6e.tar.gz
gentoo-2-cf012295e7e68515d56479ca383010fe61f7ee6e.tar.bz2
gentoo-2-cf012295e7e68515d56479ca383010fe61f7ee6e.zip
close bug 18566; update to latest version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog9
-rw-r--r--sys-devel/distcc/distcc-2.0.1.ebuild102
-rw-r--r--sys-devel/distcc/files/1.2.3/distcc-config13
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.0.11
4 files changed, 116 insertions, 9 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index cc5c94cf505f..392afec4791b 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/distcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.37 2003/03/19 19:11:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.38 2003/04/01 22:16:26 zwelch Exp $
+
+*distcc-2.0.1 (31 Mar 2003)
+
+ 31 Mar 2003; Zach Welch <zwelch@gentoo.org> distcc-2.0.1.ebuild,
+ files/1.2.3/distcc-config:
+ bump version to close bug 18566; masquerade patch now mainlined
+ info file removed upstream; add --help to distcc-config
*distcc-1.2.3-r3 (17 Mar 2003)
diff --git a/sys-devel/distcc/distcc-2.0.1.ebuild b/sys-devel/distcc/distcc-2.0.1.ebuild
new file mode 100644
index 000000000000..122aceecb9c3
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.0.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.0.1.ebuild,v 1.1 2003/04/01 22:16:26 zwelch Exp $
+
+inherit eutils
+
+IUSE=""
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc alpha ~hppa ~mips ~arm"
+
+OPV="1.2"
+LPV="1.2.3"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-libs/popt"
+
+src_unpack() {
+ unpack distcc-${PV}.tar.bz2
+# cp -a distcc-${PV} distcc-${PV}.orig
+# epatch "${FILESDIR}/${LPV}/wrapper.patch" || die
+# patch -p1 < "${FILESDIR}/${LPV}/info.patch" || die
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${LPV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${OPV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${OPV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+
+ einfo "To use distcc with **non-Portage** C compiling, add"
+ einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
+ einfo "combining this with ccache, put the distcc dir AFTER ccache."
+ einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
+ einfo "distcc into the FEATURES setting in make.conf (and define"
+ einfo "DISTCC_HOSTS as well). Do NOT set CC=distcc or similar."
+ ewarn "See http://cvs.gentoo.org/~zwelch/distcc.html for information."
+}
+
+#pkg_prerm() {
+# # ztw - not sure if this is the right place
+# distcc-config --remove-links "${CHOST}"
+# distcc-config --remove-links
+#}
+
diff --git a/sys-devel/distcc/files/1.2.3/distcc-config b/sys-devel/distcc/files/1.2.3/distcc-config
index 2fe9d0e943f2..8e2a7942651a 100644
--- a/sys-devel/distcc/files/1.2.3/distcc-config
+++ b/sys-devel/distcc/files/1.2.3/distcc-config
@@ -115,13 +115,12 @@ dccc_install_env() {
DISTCC_HOSTS="localhost"
# DISTCC_VERBOSE is not set
# DISTCC_LOG is not set
-# PATH is not set
-# ROOTPATH is not set
+# DCCC_PATH is not set
_EOF_
}
dccc_show_env() {
- grep -v '^#' ${DCCC_ENV_FILE}
+ grep -v '^#' ${DCCC_ENV_FILE} | sed -e 's,^,export ,'
}
dccc_test_env() {
@@ -243,16 +242,14 @@ case "${1}" in
eval "dccc_${SET_FUNC} ${*}"
;;
--has-path )
- dccc_test_env PATH
+ dccc_test_env DCCC_PATH
;;
--add-path )
- dccc_set_env PATH "/usr/lib/distcc/bin"
- dccc_set_env ROOTPATH "/usr/lib/distcc/bin"
+ dccc_set_env DCCC_PATH "/usr/lib/distcc/bin"
dccc_regen_env
;;
--no-path )
- dccc_set_env PATH ""
- dccc_set_env ROOTPATH ""
+ dccc_set_env DCCC_PATH ""
dccc_regen_env
;;
--show-env )
diff --git a/sys-devel/distcc/files/digest-distcc-2.0.1 b/sys-devel/distcc/files/digest-distcc-2.0.1
new file mode 100644
index 000000000000..f677f57fa249
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.0.1
@@ -0,0 +1 @@
+MD5 ffa89d1ce43b317fc67038c08200b9bc distcc-2.0.1.tar.bz2 202022