summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-09 02:37:30 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-09 02:37:30 +0000
commitcf5818e8105a6bb65cb879fe8afa14b9d6fc4811 (patch)
tree758375876f461b34b10f596d9d233751036903d6 /sys-devel
parentenable --enable-cld for unstable 4.3 versions (diff)
downloadgentoo-2-cf5818e8105a6bb65cb879fe8afa14b9d6fc4811.tar.gz
gentoo-2-cf5818e8105a6bb65cb879fe8afa14b9d6fc4811.tar.bz2
gentoo-2-cf5818e8105a6bb65cb879fe8afa14b9d6fc4811.zip
Version bump.
(Portage version: 2.2_pre7-r1/cvs/Linux 2.6.25 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-4.3.1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 76a7604338f9..25f445aa40fb 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.649 2008/05/23 02:57:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.650 2008/06/09 02:37:30 vapier Exp $
+
+*gcc-4.3.1 (09 Jun 2008)
+
+ 09 Jun 2008; Mike Frysinger <vapier@gentoo.org> +gcc-4.3.1.ebuild:
+ Version bump.
*gcc-4.2.4 (23 May 2008)
diff --git a/sys-devel/gcc/gcc-4.3.1.ebuild b/sys-devel/gcc/gcc-4.3.1.ebuild
new file mode 100644
index 000000000000..248e06cad425
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.1.ebuild,v 1.1 2008/06/09 02:37:30 vapier Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ia64"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.3
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ app-arch/zip
+ app-arch/unzip
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
+}