summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-26 18:43:39 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-26 18:43:39 +0000
commitd7cdb75f7a542b94a44157cb55268464e35854c9 (patch)
tree795bf9e6c101566fb67d0e380566d04dec36b604 /sys-devel
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-d7cdb75f7a542b94a44157cb55268464e35854c9.tar.gz
gentoo-2-d7cdb75f7a542b94a44157cb55268464e35854c9.tar.bz2
gentoo-2-d7cdb75f7a542b94a44157cb55268464e35854c9.zip
<geoman-campus> -march=mips3 -mtune=r4600 will run on any supported machine
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog5
-rw-r--r--sys-devel/gcc/gcc-3.4.0.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index bc2f6076091d..08586f2897c4 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.217 2004/04/26 18:29:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.218 2004/04/26 18:43:39 lv Exp $
+
+ 26 Apr 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0.ebuild:
+ change settings for mips again... arch set to mips3 and tune set to r4600
26 Apr 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0.ebuild:
changed mips default arch settings so that march defaults to r4k and not
diff --git a/sys-devel/gcc/gcc-3.4.0.ebuild b/sys-devel/gcc/gcc-3.4.0.ebuild
index bc4a44846cc3..c9715f9a0370 100644
--- a/sys-devel/gcc/gcc-3.4.0.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.2 2004/04/26 18:29:41 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.3 2004/04/26 18:43:39 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj hardened f77 objc uclibc"
@@ -389,7 +389,7 @@ src_compile() {
use ppc64 && myconf="${myconf} --with-cpu=g5 --with-arch=g5"
use s390 && myconf="${myconf} --with-cpu=z990 --with-arch=g5"
use x86 && myconf="${myconf} --with-cpu=pentium4 --with-arch=i586"
- use mips && myconf="${myconf} --with-arch=r4k"
+ use mips && myconf="${myconf} --with-cpu=r4600 --with-arch=mips3"
use ppc && myconf="${myconf} --with-cpu=g4 --with-arch=g3"
# In general gcc does not like optimization, and add -O2 where