summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-11 01:32:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-11 01:32:00 +0000
commitddbb575fa5b45d89aa7b8a89baced1c78816bc0e (patch)
tree28cdd20e4647a110fea06e905dd84e9007d65cf0 /sys-devel
parentNew 2005.0 profile for sparc32 (diff)
downloadgentoo-2-ddbb575fa5b45d89aa7b8a89baced1c78816bc0e.tar.gz
gentoo-2-ddbb575fa5b45d89aa7b8a89baced1c78816bc0e.tar.bz2
gentoo-2-ddbb575fa5b45d89aa7b8a89baced1c78816bc0e.zip
Version bump #77407 by Michael Cramer.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.0.ebuild54
-rw-r--r--sys-devel/bison/files/digest-bison-2.01
3 files changed, 61 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index cd7f93c1e869..c489b4f1d8cb 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.34 2005/01/11 01:19:15 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.35 2005/01/11 01:32:00 vapier Exp $
+
+*bison-2.0 (10 Jan 2005)
+
+ 10 Jan 2005; Mike Frysinger <vapier@gentoo.org> +bison-2.0.ebuild:
+ Version bump #77407 by Michael Cramer.
10 Jan 2005; Jason Wever <weeve@gentoo.org> bison-1.875d.ebuild:
Marked stable on sparc wrt bug #77435 so Spanky can't spank us
diff --git a/sys-devel/bison/bison-2.0.ebuild b/sys-devel/bison/bison-2.0.ebuild
new file mode 100644
index 000000000000..e720e5870b1a
--- /dev/null
+++ b/sys-devel/bison/bison-2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.0.ebuild,v 1.1 2005/01/11 01:32:00 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic eutils gnuconfig
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls static"
+
+DEPEND="sys-devel/m4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.32-extfix.patch
+}
+
+src_compile() {
+ # Bug 29017 says that bison has compile-time issues with
+ # -march=k6* prior to 3.4CVS. Use -march=i586 instead
+ # (04 Feb 2004 agriffis)
+ if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
+ replace-cpu-flags k6 k6-1 k6-2 i586
+ fi
+
+ econf $(use_enable nls) || die
+ use static && append-ldflags -static
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib
+
+ dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}
diff --git a/sys-devel/bison/files/digest-bison-2.0 b/sys-devel/bison/files/digest-bison-2.0
new file mode 100644
index 000000000000..0b33ffe24cec
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-2.0
@@ -0,0 +1 @@
+MD5 c17f964fd5504b88b07a183420de25e3 bison-2.0.tar.gz 1163590