summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-10-29 20:06:10 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-10-29 20:06:10 +0000
commit5aa679c28d12c70820e068b7334b742ac9abae0a (patch)
treeaf1c30e306de04c29126ba3fb5fbe0f5f823543a /sys-firmware/seabios
parentStable for HPPA (bug #439258). (diff)
downloadgentoo-2-5aa679c28d12c70820e068b7334b742ac9abae0a.tar.gz
gentoo-2-5aa679c28d12c70820e068b7334b742ac9abae0a.tar.bz2
gentoo-2-5aa679c28d12c70820e068b7334b742ac9abae0a.zip
Version bump. Use upstream's prebuilt binary when requested or when we won't be able to compile our own.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-firmware/seabios')
-rw-r--r--sys-firmware/seabios/ChangeLog9
-rw-r--r--sys-firmware/seabios/metadata.xml3
-rw-r--r--sys-firmware/seabios/seabios-1.7.1.ebuild69
3 files changed, 80 insertions, 1 deletions
diff --git a/sys-firmware/seabios/ChangeLog b/sys-firmware/seabios/ChangeLog
index f3789ce2b791..84f8091987dc 100644
--- a/sys-firmware/seabios/ChangeLog
+++ b/sys-firmware/seabios/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-firmware/seabios
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.5 2012/10/17 03:39:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.6 2012/10/29 20:06:10 cardoe Exp $
+
+*seabios-1.7.1 (29 Oct 2012)
+
+ 29 Oct 2012; Doug Goldstein <cardoe@gentoo.org> +seabios-1.7.1.ebuild,
+ metadata.xml:
+ Version bump. Use upstream's prebuilt binary when requested or when we won't
+ be able to compile our own.
17 Oct 2012; Doug Goldstein <cardoe@gentoo.org> seabios-1.7.0.ebuild:
Fix compilation issue when built under different locales. Fix by Sergei
diff --git a/sys-firmware/seabios/metadata.xml b/sys-firmware/seabios/metadata.xml
index e2d6ffdc83e2..d7ef91f65cea 100644
--- a/sys-firmware/seabios/metadata.xml
+++ b/sys-firmware/seabios/metadata.xml
@@ -6,5 +6,8 @@
<email>cardoe@gentoo.org</email>
<name>Doug Goldstein</name>
</maintainer>
+ <use>
+ <flag name='binary'>Use official upstream pre-built binaries</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-firmware/seabios/seabios-1.7.1.ebuild b/sys-firmware/seabios/seabios-1.7.1.ebuild
new file mode 100644
index 000000000000..d25b30c8b93a
--- /dev/null
+++ b/sys-firmware/seabios/seabios-1.7.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.1.ebuild,v 1.1 2012/10/29 20:06:10 cardoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+#BACKPORTS=1
+
+if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
+ EGIT_REPO_URI="git://git.seabios.org/seabios.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="http://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz
+ http://code.coreboot.org/p/seabios/downloads/get/bios.bin-${PV}.gz
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
+fi
+
+DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
+HOMEPAGE="http://www.seabios.org"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+IUSE="+binary"
+
+REQUIRED_USE="ppc ( binary )
+ ppc64 ( binary )"
+
+DEPEND="!binary? ( sys-power/iasl )"
+RDEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ if [[ -z "${EGIT_COMMIT}" ]]; then
+ sed -e "s/VERSION=.*/VERSION=${PV}/" \
+ -i "${S}/Makefile"
+ else
+ sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
+ -i "${S}/Makefile"
+ fi
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ if ! use binary ; then
+ LANG=C emake out/bios.bin
+ fi
+}
+
+src_install() {
+ insinto /usr/share/seabios
+ if ! use binary ; then
+ doins out/bios.bin
+ else
+ newins ../bios.bin-${PV} bios.bin
+ fi
+}