summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-27 21:24:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-27 21:24:08 +0000
commit45f9518a9201f898401c6072252c70ec4c0eb58f (patch)
treea1b1db35a051f9ac18e92010650523071fa631e5 /sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild
parentBump to 9.1 (diff)
downloadgentoo-2-45f9518a9201f898401c6072252c70ec4c0eb58f.tar.gz
gentoo-2-45f9518a9201f898401c6072252c70ec4c0eb58f.tar.bz2
gentoo-2-45f9518a9201f898401c6072252c70ec4c0eb58f.zip
Bump to 9.1
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild')
-rw-r--r--sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild b/sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild
new file mode 100644
index 000000000000..854fd8965a88
--- /dev/null
+++ b/sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-bin/freebsd-bin-9.1.ebuild,v 1.1 2013/01/27 21:24:08 aballier Exp $
+
+inherit bsdmk freebsd
+
+DESCRIPTION="FreeBSD /bin tools"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${BIN}.tar.bz2
+ mirror://gentoo/${UBIN}.tar.bz2
+ mirror://gentoo/${SBIN}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2"
+
+RDEPEND="=sys-freebsd/freebsd-lib-${RV}*
+ >=dev-libs/libedit-20120311.3.0-r1
+ sys-libs/ncurses
+ sys-apps/ed
+ !app-misc/realpath
+ !<sys-freebsd/freebsd-ubin-8"
+DEPEND="${RDEPEND}
+ =sys-freebsd/freebsd-mk-defs-${RV}*
+ >=sys-devel/flex-2.5.31-r2"
+
+S=${WORKDIR}/bin
+
+# csh and tcsh are provided by tcsh package, rmail is sendmail stuff.
+REMOVE_SUBDIRS="csh rmail ed"
+
+pkg_setup() {
+ mymakeopts="${mymakeopts} WITHOUT_TCSH= WITHOUT_SENDMAIL= WITHOUT_RCMDS= "
+}