summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-24 11:30:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-24 11:30:56 +0000
commit62e14a038495b738e7b56820a9b0cf3b130a29af (patch)
tree96876ac344f533c8a25fe911d40f9ab6bbf220b4 /sys-freebsd/freebsd-sources
parentSimplify to call freebsd_src_unpack, bug #444506 by Yuta SATOH (diff)
downloadgentoo-2-62e14a038495b738e7b56820a9b0cf3b130a29af.tar.gz
gentoo-2-62e14a038495b738e7b56820a9b0cf3b130a29af.tar.bz2
gentoo-2-62e14a038495b738e7b56820a9b0cf3b130a29af.zip
Simplify by using freebsd_src_unpack, by Yuta SATOH, bug #444506
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-sources')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-gentoo.patch12
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild32
3 files changed, 17 insertions, 33 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index cfbadd53b071..307ffb0ada61 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.77 2012/11/06 12:57:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.78 2012/11/24 11:30:56 aballier Exp $
+
+ 24 Nov 2012; Alexis Ballier <aballier@gentoo.org>
+ freebsd-sources-9.1_rc3.ebuild, files/freebsd-sources-9.1-gentoo.patch:
+ Simplify by using freebsd_src_unpack, by Yuta SATOH, bug #444506
*freebsd-sources-9.1_rc3 (06 Nov 2012)
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-gentoo.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-gentoo.patch
index b84d97f25c45..b02d8b68870c 100644
--- a/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-gentoo.patch
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-gentoo.patch
@@ -19,15 +19,3 @@ diff -Nur sys.orig/conf/kern.mk sys/conf/kern.mk
.else
CFLAGS+= -mno-aes -mno-avx
.endif
-diff -Nur sys.orig/dev/aic7xxx/aicasm/Makefile sys/dev/aic7xxx/aicasm/Makefile
---- sys.orig/dev/aic7xxx/aicasm/Makefile 2012-07-12 13:27:17.000000000 +0900
-+++ sys/dev/aic7xxx/aicasm/Makefile 2012-07-16 02:32:37.000000000 +0900
-@@ -14,7 +14,7 @@
- SRCS= ${GENHDRS} ${CSRCS} ${YSRCS} ${LSRCS}
- CLEANFILES+= ${GENHDRS} ${YSRCS:R:C/(.*)/\1.output/g}
- DPADD= ${LIBL}
--LDADD= -ll
-+LDADD= -lfl
- WARNS?= 5
-
- # Correct path for kernel builds
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild
index 85229ece787f..9270c495baed 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild,v 1.1 2012/11/06 12:57:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.1_rc3.ebuild,v 1.2 2012/11/24 11:30:56 aballier Exp $
inherit bsdmk freebsd flag-o-matic
@@ -23,9 +23,18 @@ MY_PVR="${PVR}"
[[ ${MY_PVR} == "${RV}" ]] && MY_PVR="${MY_PVR}-r0"
+PATCHES=( "${FILESDIR}/${PN}-9.0-disable-optimization.patch"
+ "${FILESDIR}/${PN}-9.1-gentoo.patch"
+ "${FILESDIR}/${PN}-6.0-flex-2.5.31.patch"
+ "${FILESDIR}/${PN}-6.1-ntfs.patch"
+ "${FILESDIR}/${PN}-7.1-types.h-fix.patch"
+ "${FILESDIR}/${PN}-8.0-subnet-route-pr40133.patch"
+ "${FILESDIR}/${PN}-7.1-includes.patch"
+ "${FILESDIR}/${PN}-9.0-sysctluint.patch"
+ "${FILESDIR}/${PN}-7.0-tmpfs_whiteout_stub.patch" )
+
src_unpack() {
- unpack ${A}
- cd "${S}"
+ freebsd_src_unpack
# This replaces the gentoover patch, it doesn't need reapply every time.
sed -i -e 's:^REVISION=.*:REVISION="'${PVR}'":' \
@@ -33,9 +42,6 @@ src_unpack() {
-e 's:^VERSION=.*:VERSION="${TYPE} ${BRANCH} ${REVISION}":' \
"${S}/conf/newvers.sh"
- # workaround a kernel panic for amd64-fbsd, bug #408019
- epatch "${FILESDIR}/${PN}-9.0-disable-optimization.patch"
-
# __FreeBSD_cc_version comes from FreeBSD's gcc.
# on 9.0-RELEASE it's 900001.
sed -e "s:-D_KERNEL:-D_KERNEL -D__FreeBSD_cc_version=900001:g" \
@@ -46,20 +52,6 @@ src_unpack() {
sed -e "s:-Werror:-Wno-error:g" \
-i "${S}/conf/kern.pre.mk" \
-i "${S}/conf/kmod.mk" || die
-
- epatch "${FILESDIR}/${PN}-9.1-gentoo.patch"
- epatch "${FILESDIR}/${PN}-6.0-flex-2.5.31.patch"
- sed -e 's/elf64-sparc/elf64-sparc-freebsd/g' -i "${S}/conf/ldscript.sparc64" || die
- epatch "${FILESDIR}/${PN}-6.1-ntfs.patch"
- epatch "${FILESDIR}/${PN}-7.1-types.h-fix.patch"
- epatch "${FILESDIR}/${PN}-8.0-subnet-route-pr40133.patch"
- epatch "${FILESDIR}/${PN}-7.1-includes.patch"
- epatch "${FILESDIR}/${PN}-9.0-sysctluint.patch"
-
- # By adding -DGENTOO_LIVECD to CFLAGS activate this stub
- # vop_whiteout to tmpfs, so it can be used as an overlay
- # unionfs filesystem over the cd9660 readonly filesystem.
- epatch "${FILESDIR}/${PN}-7.0-tmpfs_whiteout_stub.patch"
}
src_compile() {