summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2014-05-19 02:22:37 +0000
committerNaohiro Aota <naota@gentoo.org>2014-05-19 02:22:37 +0000
commit1accf2c9d07302a4abeeb04486b3a89410cd014f (patch)
tree1d9c1334ac2fe5237ba21a2123e969b85e6d0c92 /sys-freebsd
parentAdd Eratta patch #510534 (diff)
downloadgentoo-2-1accf2c9d07302a4abeeb04486b3a89410cd014f.tar.gz
gentoo-2-1accf2c9d07302a4abeeb04486b3a89410cd014f.tar.bz2
gentoo-2-1accf2c9d07302a4abeeb04486b3a89410cd014f.zip
Add Eratta patch #510532
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog9
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-ciss.patch65
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-9.1-r8.ebuild (renamed from sys-freebsd/freebsd-sources/freebsd-sources-9.1-r7.ebuild)5
3 files changed, 76 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index 368feb53990b..16b958c8a9c5 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.104 2014/05/08 05:24:56 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.105 2014/05/19 02:22:37 naota Exp $
+
+*freebsd-sources-9.1-r8 (19 May 2014)
+
+ 19 May 2014; Naohiro Aota <naota@gentoo.org>
+ +files/freebsd-sources-9.1-ciss.patch, +freebsd-sources-9.1-r8.ebuild,
+ -freebsd-sources-9.1-r7.ebuild:
+ Add Eratta patch #510532
*freebsd-sources-9.1-r7 (08 May 2014)
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-ciss.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-ciss.patch
new file mode 100644
index 000000000000..697984b92e74
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.1-ciss.patch
@@ -0,0 +1,65 @@
+Index: sys/dev/ciss/ciss.c
+===================================================================
+--- sys/dev/ciss/ciss.c (revision 264510)
++++ sys/dev/ciss/ciss.c (revision 264511)
+@@ -180,8 +180,6 @@
+ static void ciss_cam_poll(struct cam_sim *sim);
+ static void ciss_cam_complete(struct ciss_request *cr);
+ static void ciss_cam_complete_fixup(struct ciss_softc *sc, struct ccb_scsiio *csio);
+-static struct cam_periph *ciss_find_periph(struct ciss_softc *sc,
+- int bus, int target);
+ static int ciss_name_device(struct ciss_softc *sc, int bus, int target);
+
+ /* periodic status monitoring */
+@@ -3398,27 +3396,6 @@
+
+
+ /********************************************************************************
+- * Find a peripheral attached at (target)
+- */
+-static struct cam_periph *
+-ciss_find_periph(struct ciss_softc *sc, int bus, int target)
+-{
+- struct cam_periph *periph;
+- struct cam_path *path;
+- int status;
+-
+- status = xpt_create_path(&path, NULL, cam_sim_path(sc->ciss_cam_sim[bus]),
+- target, 0);
+- if (status == CAM_REQ_CMP) {
+- periph = cam_periph_find(path, NULL);
+- xpt_free_path(path);
+- } else {
+- periph = NULL;
+- }
+- return(periph);
+-}
+-
+-/********************************************************************************
+ * Name the device at (target)
+ *
+ * XXX is this strictly correct?
+@@ -3427,12 +3404,22 @@
+ ciss_name_device(struct ciss_softc *sc, int bus, int target)
+ {
+ struct cam_periph *periph;
++ struct cam_path *path;
++ int status;
+
+ if (CISS_IS_PHYSICAL(bus))
+ return (0);
+- if ((periph = ciss_find_periph(sc, bus, target)) != NULL) {
++
++ status = xpt_create_path(&path, NULL, cam_sim_path(sc->ciss_cam_sim[bus]),
++ target, 0);
++
++ if (status == CAM_REQ_CMP) {
++ mtx_lock(&sc->ciss_mtx);
++ periph = cam_periph_find(path, NULL);
+ sprintf(sc->ciss_logical[bus][target].cl_name, "%s%d",
+ periph->periph_name, periph->unit_number);
++ mtx_unlock(&sc->ciss_mtx);
++ xpt_free_path(path);
+ return(0);
+ }
+ sc->ciss_logical[bus][target].cl_name[0] = 0;
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r7.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r8.ebuild
index 7806f0c93fa5..7eccf479de4a 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r7.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r7.ebuild,v 1.1 2014/05/08 05:24:55 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r8.ebuild,v 1.1 2014/05/19 02:22:37 naota Exp $
inherit bsdmk freebsd flag-o-matic
@@ -40,7 +40,8 @@ PATCHES=( "${FILESDIR}/${PN}-9.0-disable-optimization.patch"
"${FILESDIR}/${PN}-9.1-cve-2014-1453.patch"
"${FILESDIR}/${PN}-9.1-random.patch"
"${FILESDIR}/${PN}-9.1-mmap-2014.patch"
- "${FILESDIR}/${PN}-9.1-tcp.patch" )
+ "${FILESDIR}/${PN}-9.1-tcp.patch"
+ "${FILESDIR}/${PN}-9.1-ciss.patch" )
src_unpack() {
freebsd_src_unpack