summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-03-05 07:49:13 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-03-05 07:49:13 +0000
commite23cb8c986b90abd420d56180cdb7a342c76ed75 (patch)
tree5495651a016ecfec205acbb566b6501eae68f290 /sys-fs/ddrescue
parentMissing app-arch/unzip DEPEND for USE="test" wrt #406793 by Toralf Förster (diff)
downloadgentoo-2-e23cb8c986b90abd420d56180cdb7a342c76ed75.tar.gz
gentoo-2-e23cb8c986b90abd420d56180cdb7a342c76ed75.tar.bz2
gentoo-2-e23cb8c986b90abd420d56180cdb7a342c76ed75.zip
Version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ddrescue')
-rw-r--r--sys-fs/ddrescue/ChangeLog9
-rw-r--r--sys-fs/ddrescue/ddrescue-1.15.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-fs/ddrescue/ChangeLog b/sys-fs/ddrescue/ChangeLog
index 97c745c8eed2..992266dbda4e 100644
--- a/sys-fs/ddrescue/ChangeLog
+++ b/sys-fs/ddrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ddrescue
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.32 2011/08/08 07:28:42 polynomial-c Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.33 2012/03/05 07:49:13 polynomial-c Exp $
+
+*ddrescue-1.15 (05 Mar 2012)
+
+ 05 Mar 2012; Lars Wendler <polynomial-c@gentoo.org> +ddrescue-1.15.ebuild:
+ Version bump.
08 Aug 2011; Lars Wendler <polynomial-c@gentoo.org> -ddrescue-1.12.ebuild,
-ddrescue-1.13.ebuild:
diff --git a/sys-fs/ddrescue/ddrescue-1.15.ebuild b/sys-fs/ddrescue/ddrescue-1.15.ebuild
new file mode 100644
index 000000000000..6eef515ca3c5
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.15.ebuild,v 1.1 2012/03/05 07:49:13 polynomial-c Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Copies data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # not a normal configure script
+ ./configure \
+ --prefix=/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man || die "make install failed"
+ dodoc ChangeLog README NEWS AUTHORS
+}