summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-06 22:48:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-06 22:48:20 +0000
commit9f8edcde358fb7875dd1e6b0de1829c96bb5b41d (patch)
tree35de28ebe57b234ee5883c06d145b4b0dc0b9ddd /sys-fs/e2fsprogs
parentManifest recommit for earlier version bump. (diff)
downloadgentoo-2-9f8edcde358fb7875dd1e6b0de1829c96bb5b41d.tar.gz
gentoo-2-9f8edcde358fb7875dd1e6b0de1829c96bb5b41d.tar.bz2
gentoo-2-9f8edcde358fb7875dd1e6b0de1829c96bb5b41d.zip
old
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild9
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild119
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.351
3 files changed, 5 insertions, 124 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild
index aa2e1edc1271..ced3db9aad94 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild,v 1.16 2005/01/18 13:15:57 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.35-r1.ebuild,v 1.17 2005/02/06 22:48:20 vapier Exp $
inherit eutils flag-o-matic gnuconfig toolchain-funcs
@@ -21,13 +21,14 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
+ cd ${S}
# Fix a cosmetic error in mk_cmds's help output.
- cd ${S}; epatch ${FILESDIR}/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Userpriv fix. Closes #27348
- chmod u+w po/*.po
+ epatch ${FILESDIR}/e2fsprogs-1.32-mk_cmds-cosmetic.patch
# Patch to make the configure and sed scripts more friendly to,
# for example, the Estonian locale
epatch ${FILESDIR}/${PN}-sed-locale.patch
+ # Userpriv fix. Closes #27348
+ chmod u+w po/*.po
gnuconfig_update
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild
deleted file mode 100644
index b9449e44d528..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.35.ebuild,v 1.18 2005/01/03 00:10:40 ciaranm Exp $
-
-inherit eutils flag-o-matic gnuconfig
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ~ppc64 s390"
-IUSE="nls static"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-RDEPEND="virtual/libc"
-
-src_unpack() {
- unpack ${A}
- # Fix a cosmetic error in mk_cmds's help output.
- cd ${S}; epatch ${FILESDIR}/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Userpriv fix. Closes #27348
- chmod u+w po/*.po
- # Patch to make the configure and sed scripts more friendly to,
- # for example, the Estonian locale
- epatch ${FILESDIR}/${PN}-sed-locale.patch
-
- gnuconfig_update
-}
-
-src_compile() {
- local myconf
-
- export LDCONFIG=/bin/true
-
- # building e2fsprogs on sparc results in silo breaking
- [ "${ARCH}" = "sparc" ] && filter-flags "-fstack-protector"
-
- use static \
- && myconf="${myconf} --with-ldopts=-static" \
- || myconf="${myconf} --enable-dynamic-e2fsck --enable-elf-shlibs"
-
- econf \
- `use_enable nls` \
- ${myconf} || die
-
- # Parallel make sometimes fails
- emake -j1 || die
-}
-
-src_install() {
- einstall libdir=zapme || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- #There is .po file b0rkage with 1.33; commenting this out (drobbins, 21 Apr 2003)
- #if use nls; then
- # make -C po DESTDIR=${D} install || die
- #fi
-
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /lib /bin /sbin
- cd ${D}/usr/lib
- mv * ../../lib
- cd ${D}/lib
- mv *.a ../usr/lib
- local mylib=""
- local x=""
- #install ldscripts to fix bug #4411
- cd ${D}/usr/lib
- for x in *.a
- do
- [ ! -f ${x} ] && continue
- gen_usr_ldscript ${x/a}so
- done
- #normalize evil symlinks
- cd ${D}/lib
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib="`readlink ${x}`"
- mylib="`basename ${mylib}`"
- ln -sf ${mylib} ${x}
- done
-
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../../bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
- ln -sf mke2fs mkfs.ext3
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
-
- cd ${S}/lib/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/lib/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35
deleted file mode 100644
index 38322e76f0f4..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.35
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8d25ffd60d405ef32d341704a2323807 e2fsprogs-1.35.tar.gz 3152299