summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-07-25 15:31:49 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-07-25 15:31:49 +0000
commit25a6f5df34f2bb6fda57038cf6b5af1e38317e9f (patch)
tree00fd08b6aaa9cb729c95586fe1901ff6d4383d36 /sys-fs/eudev
parentFix SRC_URI (diff)
downloadgentoo-2-25a6f5df34f2bb6fda57038cf6b5af1e38317e9f.tar.gz
gentoo-2-25a6f5df34f2bb6fda57038cf6b5af1e38317e9f.tar.bz2
gentoo-2-25a6f5df34f2bb6fda57038cf6b5af1e38317e9f.zip
fix tests - add missing deps and provide exclusions to sandbox, bug 478092
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-fs/eudev')
-rw-r--r--sys-fs/eudev/ChangeLog6
-rw-r--r--sys-fs/eudev/eudev-1.0.ebuild6
-rw-r--r--sys-fs/eudev/eudev-1.1.ebuild22
-rw-r--r--sys-fs/eudev/eudev-1.2_beta.ebuild26
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild21
5 files changed, 64 insertions, 17 deletions
diff --git a/sys-fs/eudev/ChangeLog b/sys-fs/eudev/ChangeLog
index f11d41c7c403..ff68e9474d71 100644
--- a/sys-fs/eudev/ChangeLog
+++ b/sys-fs/eudev/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/eudev
# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.49 2013/07/25 07:52:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.50 2013/07/25 15:31:49 axs Exp $
+
+ 25 Jul 2013; Ian Stakenvicius <axs@gentoo.org> eudev-1.0.ebuild,
+ eudev-1.1.ebuild, eudev-1.2_beta.ebuild, eudev-9999.ebuild:
+ fix tests - add missing deps and provide exclusions to sandbox, bug 478092
25 Jul 2013; Patrick Lauer <patrick@gentoo.org> eudev-1.2_beta.ebuild:
Add missing test dep
diff --git a/sys-fs/eudev/eudev-1.0.ebuild b/sys-fs/eudev/eudev-1.0.ebuild
index f9821df21186..b4c3c22d4568 100644
--- a/sys-fs/eudev/eudev-1.0.ebuild
+++ b/sys-fs/eudev/eudev-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.0.ebuild,v 1.3 2013/07/24 17:09:41 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.0.ebuild,v 1.4 2013/07/25 15:31:49 axs Exp $
EAPI="5"
@@ -195,7 +195,9 @@ pkg_postinst()
einfo "Removed unneeded file 64-device-mapper.rules"
fi
- use hwdb && udevadm hwdb --update --root="${ROOT%/}"
+ if use hwdb && has_version 'sys-apps/hwids[udev]'; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
ewarn
ewarn "You need to restart eudev as soon as possible to make the"
diff --git a/sys-fs/eudev/eudev-1.1.ebuild b/sys-fs/eudev/eudev-1.1.ebuild
index beeb8b0654a6..703fd15a84a4 100644
--- a/sys-fs/eudev/eudev-1.1.ebuild
+++ b/sys-fs/eudev/eudev-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.1.ebuild,v 1.4 2013/07/24 17:09:41 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.1.ebuild,v 1.5 2013/07/25 15:31:49 axs Exp $
EAPI="5"
@@ -22,7 +22,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
-IUSE="doc gudev hwdb kmod introspection keymap +modutils +openrc +rule-generator selinux static-libs"
+IUSE="doc gudev hwdb kmod introspection keymap +modutils +openrc +rule-generator selinux static-libs test"
COMMON_DEPEND="gudev? ( dev-libs/glib:2 )
kmod? ( sys-apps/kmod )
@@ -39,7 +39,8 @@ DEPEND="${COMMON_DEPEND}
!<sys-kernel/linux-headers-${KV_min}
doc? ( dev-util/gtk-doc )
app-text/docbook-xsl-stylesheets
- dev-libs/libxslt"
+ dev-libs/libxslt
+ test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
hwdb? ( >=sys-apps/hwids-20121202.2[udev] )
@@ -142,6 +143,17 @@ src_configure()
econf "${econf_args[@]}"
}
+src_test() {
+ # make sandbox get out of the way
+ # these are safe because there is a fake root filesystem put in place,
+ # but sandbox seems to evaluate the paths of the test i/o instead of the
+ # paths of the actual i/o that results.
+ addread /sys
+ addwrite /dev
+ addwrite /run
+ default_src_test
+}
+
src_install()
{
emake DESTDIR="${D}" install
@@ -193,7 +205,9 @@ pkg_postinst()
einfo "Removed unneeded file 64-device-mapper.rules"
fi
- use hwdb && udevadm hwdb --update --root="${ROOT%/}"
+ if use hwdb && has_version 'sys-apps/hwids[udev]'; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
ewarn
ewarn "You need to restart eudev as soon as possible to make the"
diff --git a/sys-fs/eudev/eudev-1.2_beta.ebuild b/sys-fs/eudev/eudev-1.2_beta.ebuild
index 0bcb32437895..156f32a3e5d8 100644
--- a/sys-fs/eudev/eudev-1.2_beta.ebuild
+++ b/sys-fs/eudev/eudev-1.2_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2_beta.ebuild,v 1.2 2013/07/25 07:52:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2_beta.ebuild,v 1.3 2013/07/25 15:31:49 axs Exp $
EAPI="5"
@@ -41,10 +41,11 @@ DEPEND="${COMMON_DEPEND}
doc? ( dev-util/gtk-doc )
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
- test? ( app-text/tree )"
+ test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
hwdb? ( >=sys-apps/hwids-20121202.2[udev] )
+ keymap? ( >=sys-apps/hwids-20130717-r1[udev] )
!sys-fs/udev
!sys-apps/coldplug
!sys-apps/systemd
@@ -55,6 +56,8 @@ RDEPEND="${COMMON_DEPEND}
PDEPEND=">=virtual/udev-180
openrc? ( >=sys-fs/udev-init-scripts-18 )"
+REQUIRED_USE="keymap? ( hwdb )"
+
S="${WORKDIR}/${PN}-1.1"
pkg_pretend()
@@ -124,10 +127,6 @@ src_configure()
local econf_args
econf_args=(
- ac_cv_search_cap_init=
- ac_cv_header_sys_capability_h=yes
- DBUS_CFLAGS=' '
- DBUS_LIBS=' '
--with-rootprefix=
--docdir=/usr/share/doc/${PF}
--libdir=/usr/$(get_libdir)
@@ -149,6 +148,17 @@ src_configure()
econf "${econf_args[@]}"
}
+src_test() {
+ # make sandbox get out of the way
+ # these are safe because there is a fake root filesystem put in place,
+ # but sandbox seems to evaluate the paths of the test i/o instead of the
+ # paths of the actual i/o that results.
+ addread /sys
+ addwrite /dev
+ addwrite /run
+ default_src_test
+}
+
src_install()
{
emake DESTDIR="${D}" install
@@ -200,7 +210,9 @@ pkg_postinst()
einfo "Removed unneeded file 64-device-mapper.rules"
fi
- use hwdb && udevadm hwdb --update --root="${ROOT%/}"
+ if use hwdb && has_version 'sys-apps/hwids[udev]'; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
ewarn
ewarn "You need to restart eudev as soon as possible to make the"
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index e07a0ab11cb1..ee88c2627c97 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.33 2013/07/24 20:49:11 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.34 2013/07/25 15:31:49 axs Exp $
EAPI="5"
@@ -22,7 +22,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
-IUSE="doc gudev hwdb kmod introspection keymap +modutils +openrc +rule-generator selinux static-libs"
+IUSE="doc gudev hwdb kmod introspection keymap +modutils +openrc +rule-generator selinux static-libs test"
COMMON_DEPEND="gudev? ( dev-libs/glib:2 )
kmod? ( sys-apps/kmod )
@@ -39,10 +39,12 @@ DEPEND="${COMMON_DEPEND}
!<sys-kernel/linux-headers-${KV_min}
doc? ( dev-util/gtk-doc )
app-text/docbook-xsl-stylesheets
- dev-libs/libxslt"
+ dev-libs/libxslt
+ test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
hwdb? ( >=sys-apps/hwids-20121202.2[udev] )
+ keymap? ( >=sys-apps/hwids-20130717-r1[udev] )
!sys-fs/udev
!sys-apps/coldplug
!sys-apps/systemd
@@ -53,6 +55,8 @@ RDEPEND="${COMMON_DEPEND}
PDEPEND=">=virtual/udev-180
openrc? ( >=sys-fs/udev-init-scripts-18 )"
+REQUIRED_USE="keymap? ( hwdb )"
+
pkg_pretend()
{
if ! use rule-generator; then
@@ -141,6 +145,17 @@ src_configure()
econf "${econf_args[@]}"
}
+src_test() {
+ # make sandbox get out of the way
+ # these are safe because there is a fake root filesystem put in place,
+ # but sandbox seems to evaluate the paths of the test i/o instead of the
+ # paths of the actual i/o that results.
+ addread /sys
+ addwrite /dev
+ addwrite /run
+ default_src_test
+}
+
src_install()
{
emake DESTDIR="${D}" install