summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-11-03 10:03:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-11-03 10:03:44 +0000
commitab7c63d69499e998b53da8d74709098ed4302cdb (patch)
treead04fec1bc73171f9fd24273e0731d425c5d042d /sys-fs/ext3grep
parentold (diff)
downloadgentoo-2-ab7c63d69499e998b53da8d74709098ed4302cdb.tar.gz
gentoo-2-ab7c63d69499e998b53da8d74709098ed4302cdb.tar.bz2
gentoo-2-ab7c63d69499e998b53da8d74709098ed4302cdb.zip
Fix building with recent toolchain wrt #422789 by Diego Elio Pettenò. Missing dependencies of e2fsprogs, os-headers, and pkg-config.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs/ext3grep')
-rw-r--r--sys-fs/ext3grep/ChangeLog7
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2.ebuild21
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch15
3 files changed, 33 insertions, 10 deletions
diff --git a/sys-fs/ext3grep/ChangeLog b/sys-fs/ext3grep/ChangeLog
index 8b151356637d..6ae3c1ae4547 100644
--- a/sys-fs/ext3grep/ChangeLog
+++ b/sys-fs/ext3grep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ext3grep
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ChangeLog,v 1.6 2012/11/03 09:53:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ChangeLog,v 1.7 2012/11/03 10:03:44 ssuominen Exp $
+
+ 03 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> ext3grep-0.10.2.ebuild,
+ +files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch:
+ Fix building with recent toolchain wrt #422789 by Diego Elio Pettenò.
+ Missing dependencies of e2fsprogs, os-headers, and pkg-config.
03 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -ext3grep-0.10.1.ebuild:
old
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
index 04293ffeaee0..9a6dc3f180fa 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.2.ebuild,v 1.3 2012/02/26 17:51:44 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext3grep/ext3grep-0.10.2.ebuild,v 1.4 2012/11/03 10:03:44 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit eutils
DESCRIPTION="Recover deleted files on an ext3 file system"
@@ -14,8 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug pch"
+DOCS="NEWS README"
+
+RDEPEND=""
+DEPEND="sys-fs/e2fsprogs
+ virtual/os-headers
+ virtual/pkgconfig"
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.10.1-gcc44.patch
+ epatch \
+ "${FILESDIR}"/${PN}-0.10.1-gcc44.patch \
+ "${FILESDIR}"/${P}-include-unistd_h-for-sysconf.patch
# Fix build against latest e2fsprogs, taken from
# https://code.google.com/p/ext3grep/issues/detail?id=34
@@ -24,12 +33,6 @@ src_prepare() {
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable debug) \
$(use_enable pch)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc NEWS README || die
-}
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch b/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
new file mode 100644
index 000000000000..bf38c27e7095
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/422789
+
+--- src/init_consts.cc
++++ src/init_consts.cc
+@@ -27,6 +27,10 @@
+ #include "debug.h"
+ #endif
+
++#if USE_MMAP
++#include <unistd.h> /* sysconf */
++#endif
++
+ #include "globals.h"
+ #include "superblock.h"
+ #include "forward_declarations.h"