summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-28 23:22:20 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-28 23:22:20 +0000
commita6075402267491c78d0d62d7c9fdb985c911d434 (patch)
tree2b8c36a1061bf531978e3c8d787c4c852591aa0a /sys-fs/inotify-tools
parentstable x86, security bug 290710 (diff)
downloadgentoo-2-a6075402267491c78d0d62d7c9fdb985c911d434.tar.gz
gentoo-2-a6075402267491c78d0d62d7c9fdb985c911d434.tar.bz2
gentoo-2-a6075402267491c78d0d62d7c9fdb985c911d434.zip
Fix implicit doxygen handling, broken autotools, and install more doc files #177054 by Mart Raudsepp.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/ChangeLog9
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild35
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-fs/inotify-tools/ChangeLog b/sys-fs/inotify-tools/ChangeLog
index 1fe15ae6f48e..60445da3a60f 100644
--- a/sys-fs/inotify-tools/ChangeLog
+++ b/sys-fs/inotify-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/inotify-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/inotify-tools/ChangeLog,v 1.26 2009/09/23 20:51:05 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/inotify-tools/ChangeLog,v 1.27 2009/10/28 23:22:20 vapier Exp $
+
+*inotify-tools-3.13-r1 (28 Oct 2009)
+
+ 28 Oct 2009; Mike Frysinger <vapier@gentoo.org>
+ +inotify-tools-3.13-r1.ebuild:
+ Fix implicit doxygen handling, broken autotools, and install more doc
+ files #177054 by Mart Raudsepp.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> inotify-tools-3.12.ebuild,
inotify-tools-3.13.ebuild:
diff --git a/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild b/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild
new file mode 100644
index 000000000000..0d81e5e4f42d
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/inotify-tools/inotify-tools-3.13-r1.ebuild,v 1.1 2009/10/28 23:22:20 vapier Exp $
+
+EAPI="2"
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="http://inotify-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~arm"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ # timestamps are busted in tarball
+ find . -type f -exec touch -r configure {} +
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ econf \
+ --docdir=/usr/share/doc/${PF}/html \
+ $(use_enable doc doxygen) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README NEWS AUTHORS ChangeLog
+}