summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-21 05:28:00 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-21 05:28:00 +0000
commite1f474af1a1097096d4869093872740c0981cb8b (patch)
treee0ca0a8c6ef1db0fbe9ace9bd261553fddc0fedd /sys-fs/multipath-tools/files
parenttidy. Install to libdir instead of libexecdir (diff)
downloadgentoo-2-e1f474af1a1097096d4869093872740c0981cb8b.tar.gz
gentoo-2-e1f474af1a1097096d4869093872740c0981cb8b.tar.bz2
gentoo-2-e1f474af1a1097096d4869093872740c0981cb8b.zip
Respect LDFLAGS when linking shared libs.
Diffstat (limited to 'sys-fs/multipath-tools/files')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch57
1 files changed, 49 insertions, 8 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch b/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch
index 336f3468ab10..60faba149fea 100644
--- a/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch
@@ -1,5 +1,5 @@
---- multipath-tools-0.4.9.orig/kpartx/Makefile 2010-05-22 05:01:58.000000000 -0700
-+++ multipath-tools-0.4.9/kpartx/Makefile 2010-11-28 12:14:25.763531104 -0800
+--- a/kpartx/Makefile
++++ b/kpartx/Makefile
@@ -6,7 +6,7 @@
CFLAGS += -I. -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
@@ -38,8 +38,8 @@
clean:
- rm -f core *.o $(EXEC) *.gz
+ rm -f core *.o $(EXEC)
---- multipath-tools-0.4.9.orig/Makefile.inc 2010-05-22 05:01:58.000000000 -0700
-+++ multipath-tools-0.4.9/Makefile.inc 2010-11-28 12:14:25.763531104 -0800
+--- a/Makefile.inc
++++ b/Makefile.inc
@@ -32,11 +32,10 @@
syslibdir = $(prefix)/$(LIB)
libdir = $(prefix)/$(LIB)/multipath
@@ -54,8 +54,8 @@
SHARED_FLAGS = -shared
%.o: %.c
---- multipath-tools-0.4.9.orig/multipath/Makefile 2010-05-22 05:01:58.000000000 -0700
-+++ multipath-tools-0.4.9/multipath/Makefile 2010-11-28 12:14:46.718697048 -0800
+--- a/multipath/Makefile
++++ b/multipath/Makefile
@@ -7,32 +7,30 @@
OBJS = main.o
@@ -99,8 +99,8 @@
clean:
- rm -f core *.o $(EXEC) *.gz
+ rm -f core *.o $(EXEC)
---- multipath-tools-0.4.9.orig/multipathd/Makefile 2010-05-22 05:01:58.000000000 -0700
-+++ multipath-tools-0.4.9/multipathd/Makefile 2010-11-28 12:15:46.624171566 -0800
+--- a/multipathd/Makefile
++++ b/multipathd/Makefile
@@ -6,8 +6,8 @@
# basic flags setting
#
@@ -138,3 +138,44 @@
- rm -f core *.o $(EXEC) *.gz
+ rm -f core *.o $(EXEC)
+--- a/libmultipath/Makefile
++++ b/libmultipath/Makefile
+@@ -26,7 +26,7 @@ endif
+ all: $(LIBS)
+
+ $(LIBS): $(OBJS)
+- $(CC) $(SHARED_FLAGS) $(LIBDEPS) -Wl,-soname=$@ $(CFLAGS) -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) $(SHARED_FLAGS) $(LIBDEPS) -Wl,-soname=$@ $(CFLAGS) -o $@ $(OBJS)
+ ln -sf $@ $(DEVLIB)
+
+ install:
+--- a/libmultipath/checkers/Makefile
++++ b/libmultipath/checkers/Makefile
+@@ -18,10 +18,10 @@ CFLAGS += -I..
+ all: $(LIBS)
+
+ libcheckdirectio.so: libsg.o directio.o
+- $(CC) $(SHARED_FLAGS) -o $@ $^ -laio
++ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^ -laio
+
+ libcheck%.so: libsg.o %.o
+- $(CC) $(SHARED_FLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
+
+ install:
+ $(INSTALL_PROGRAM) -m 755 $(LIBS) $(DESTDIR)$(libdir)
+--- a/libmultipath/prioritizers/Makefile
++++ b/libmultipath/prioritizers/Makefile
+@@ -20,10 +20,10 @@ CFLAGS += -I..
+ all: $(LIBS)
+
+ libprioalua.so: alua.o alua_rtpg.o
+- $(CC) $(SHARED_FLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
+
+ libprio%.so: %.o
+- $(CC) $(SHARED_FLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) $(SHARED_FLAGS) -o $@ $^
+
+ install: $(LIBS)
+ $(INSTALL_PROGRAM) -m 755 libprio*.so $(DESTDIR)$(libdir)