summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-08-09 17:47:34 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-08-09 17:47:34 +0000
commit482099b6e98873f66be4e98b4021a2382ddd8549 (patch)
tree78b238c23b529011adfc3d6fcaaba5d7d51d3b89 /sys-fs/ntfs3g
parentMake polkit a PDEP to avoid circular dependency. Bug #480328. (diff)
downloadgentoo-2-482099b6e98873f66be4e98b4021a2382ddd8549.tar.gz
gentoo-2-482099b6e98873f66be4e98b4021a2382ddd8549.tar.bz2
gentoo-2-482099b6e98873f66be4e98b4021a2382ddd8549.zip
Add die in pkg_pretend when attempting to build with gold (bug #450024), copied from grub.
(Portage version: 2.1.13.5/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog6
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild13
2 files changed, 17 insertions, 2 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 1aa2dd1c49f2..bd7f127f8be7 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.147 2013/06/09 23:04:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.148 2013/08/09 17:47:34 chutzpah Exp $
+
+ 09 Aug 2013; Patrick McLean <chutzpah@gentoo.org> ntfs3g-2013.1.13.ebuild:
+ Add die in pkg_pretend when attempting to build with gold (bug #450024),
+ copied from grub.
09 Jun 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml:
Add upstream CPE tag (security info) from ChromiumOS.
diff --git a/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild b/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
index 1a0a3b071527..24ecb45efeae 100644
--- a/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild,v 1.3 2013/02/22 17:35:27 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild,v 1.4 2013/08/09 17:47:34 chutzpah Exp $
EAPI=5
inherit eutils linux-info udev
@@ -79,3 +79,14 @@ src_install() {
dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug 450024
+ if $(tc-getLD) --version | grep -q "GNU gold"; then
+ eerror "ntfs-3g does not function correctly when built with the gold linker."
+ eerror "Please select the bfd linker with binutils-config."
+ die "GNU gold detected"
+ fi
+ fi
+}