summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-01-29 19:27:22 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-01-29 19:27:22 +0000
commit1200d43695b575ba0270eabc8bf3d9c5a0ecccba (patch)
tree1d0bc3e4f0b6abf89806a284a14a6023a4559485 /sys-fs/udev
parentA number of fixes (diff)
downloadgentoo-2-1200d43695b575ba0270eabc8bf3d9c5a0ecccba.tar.gz
gentoo-2-1200d43695b575ba0270eabc8bf3d9c5a0ecccba.tar.bz2
gentoo-2-1200d43695b575ba0270eabc8bf3d9c5a0ecccba.zip
Enable bootup with empty /dev on root-partition, Bug #151414. Setting IN_HOTPLUG for all events for compatibility.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog10
-rw-r--r--sys-fs/udev/files/05-udev-early.rules-104-r513
-rw-r--r--sys-fs/udev/files/digest-udev-104-r53
-rw-r--r--sys-fs/udev/files/udev-start-104-r5.sh150
-rw-r--r--sys-fs/udev/udev-104-r5.ebuild277
5 files changed, 452 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 744cda850c94..e28e61ea3773 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.234 2007/01/28 23:14:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.235 2007/01/29 19:27:22 zzam Exp $
+
+*udev-104-r5 (29 Jan 2007)
+
+ 29 Jan 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/05-udev-early.rules-104-r5, +files/udev-start-104-r5.sh,
+ +udev-104-r5.ebuild:
+ Enable bootup with empty /dev on root-partition, Bug #151414. Setting
+ IN_HOTPLUG for all events for compatibility.
28 Jan 2007; Mike Frysinger <vapier@gentoo.org> udev-103.ebuild,
udev-104-r3.ebuild, udev-104-r4.ebuild:
diff --git a/sys-fs/udev/files/05-udev-early.rules-104-r5 b/sys-fs/udev/files/05-udev-early.rules-104-r5
new file mode 100644
index 000000000000..b4d24ae21698
--- /dev/null
+++ b/sys-fs/udev/files/05-udev-early.rules-104-r5
@@ -0,0 +1,13 @@
+# ignore these events until someone needs them
+SUBSYSTEM=="drivers", OPTIONS="ignore_device"
+SUBSYSTEM=="module", OPTIONS="ignore_device"
+
+# sysfs is populated after the event is sent
+ACTION=="add", DEVPATH=="/devices/*", ENV{PHYSDEVBUS}=="?*", WAIT_FOR_SYSFS="bus"
+ACTION=="add", SUBSYSTEM=="scsi", WAIT_FOR_SYSFS="ioerr_cnt"
+ACTION=="add", SUBSYSTEM=="net", WAIT_FOR_SYSFS="address"
+ACTION=="add", SUBSYSTEM=="net", ENV{PHYSDEVDRIVER}=="?*", WAIT_FOR_SYSFS="device/driver"
+
+# Set IN_HOTPLUG for compatibility with init-scripts called from udev
+ENV{IN_HOTPLUG}="1"
+
diff --git a/sys-fs/udev/files/digest-udev-104-r5 b/sys-fs/udev/files/digest-udev-104-r5
new file mode 100644
index 000000000000..1d88fbeee74a
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-104-r5
@@ -0,0 +1,3 @@
+MD5 9bcfc782d40db2b406a9c1172defda8f udev-104.tar.bz2 187574
+RMD160 269aeb9a0b2043d18c274fde749d2e0d30398b73 udev-104.tar.bz2 187574
+SHA256 ec0e7bd0c322dce6149d5f94185aa477659f5030a3d684ff5428124eca684ea1 udev-104.tar.bz2 187574
diff --git a/sys-fs/udev/files/udev-start-104-r5.sh b/sys-fs/udev/files/udev-start-104-r5.sh
new file mode 100644
index 000000000000..9e69b027d52f
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-104-r5.sh
@@ -0,0 +1,150 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+udev_version() {
+ # Version number copied in by ebuild
+ local version=@@UDEV_VERSION@@
+ version=${version##0}
+
+ echo "${version}"
+}
+
+populate_udev() {
+ # populate /dev with devices already found by the kernel
+ if [ $(get_KV) -gt "$(KV_to_int '2.6.14')" ] ; then
+ ebegin "Populating /dev with existing devices through uevents"
+ local opts=
+ [[ ${RC_COLDPLUG} != "yes" && $(udev_version) -ge "96" ]] && \
+ opts="--attr-match=dev"
+ /sbin/udevtrigger ${opts}
+ eend $?
+ else
+ ebegin "Populating /dev with existing devices with udevstart"
+ /sbin/udevstart
+ eend $?
+ fi
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ /sbin/udevsettle --timeout=60
+ eend $?
+
+ return 0
+}
+
+seed_dev() {
+ # Seed /dev with some things that we know we need
+ ebegin "Seeding /dev with needed nodes"
+
+ # if /dev/console is missing on root-partition,
+ # kernel could not open it and we need to do that for
+ # udevd (Bug #151414)
+ mknod /dev/console c 5 1
+
+ # udevd will dup its stdin/stdout/stderr to /dev/null
+ # and we do not want a file which gets buffered in ram
+ mknod /dev/null c 1 3
+
+ # copy over any persistant things
+ if [[ -d /lib/udev/devices ]] ; then
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev 2>/dev/null
+ fi
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [[ -e /proc/kcore ]] && ln -snf /proc/kcore /dev/core
+
+ # Create problematic directories
+ mkdir -p /dev/{pts,shm}
+ eend 0
+}
+
+main() {
+ # check if /dev/console exists outside tmpfs
+ [[ -c /dev/console ]] ; local need_redirect=$?
+
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [[ ${RC_USE_FSTAB} == "yes" ]] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [[ -n ${mntcmd} ]] ; then
+ try mount -n ${mntcmd}
+ else
+ # This is bash only, but saves on using grep
+ if [[ $(</proc/filesystems)$'\n' =~ [[:space:]]tmpfs$'\n' ]] ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ # many video drivers require exec access in /dev #92921
+ try mount -n -t ${mntcmd} udev /dev -o exec,nosuid,mode=0755
+ fi
+ eend $?
+
+ # Create a file so that our rc system knows it's still in sysinit.
+ # Existance means init scripts will not directly run.
+ # rc will remove the file when done with sysinit.
+ touch /dev/.rcsysinit
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [[ -x /sbin/restorecon && -c /selinux/null ]] ; then
+ restorecon /dev &> /selinux/null
+ fi
+
+ # Actually get udev rolling
+ if [[ ${RC_DEVICE_TARBALL} == "yes" && \
+ -s /lib/udev/state/devices.tar.bz2 ]] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev/state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+
+ seed_dev
+
+ # Setup hotplugging (if possible)
+ if [[ -e /proc/sys/kernel/hotplug ]] ; then
+ ebegin "Setting up proper hotplug agent"
+ eindent
+ if [[ $(get_KV) -gt $(KV_to_int '2.6.14') ]] ; then
+ einfo "Using netlink for hotplug events..."
+ echo "" > /proc/sys/kernel/hotplug
+ else
+ einfo "Setting /sbin/udevsend as hotplug agent ..."
+ echo "/sbin/udevsend" > /proc/sys/kernel/hotplug
+ fi
+ eoutdent
+ eend 0
+ fi
+
+ ebegin "Starting udevd"
+ if [[ ${need_redirect} == 1 ]]; then
+ # we need to open fds 0 1 2 to solve Bug #151414
+ /sbin/udevd --daemon </dev/console >/dev/console 2>/dev/console
+ else
+ /sbin/udevd --daemon
+ fi
+ eend $?
+
+ populate_udev
+
+ # Create nodes that udev can't
+ ebegin "Finalizing udev configuration"
+ [[ -x /sbin/dmsetup ]] && /sbin/dmsetup mknodes &>/dev/null
+ [[ -x /sbin/lvm ]] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ # Running evms_activate on a LiveCD causes lots of headaches
+ [[ -z ${CDBOOT} ]] && [[ -x /sbin/evms_activate ]] && \
+ /sbin/evms_activate -q &>/dev/null
+ eend 0
+}
+
+main
+
+# vim:ts=4
diff --git a/sys-fs/udev/udev-104-r5.ebuild b/sys-fs/udev/udev-104-r5.ebuild
new file mode 100644
index 000000000000..3d43c260ed47
--- /dev/null
+++ b/sys-fs/udev/udev-104-r5.ebuild
@@ -0,0 +1,277 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-104-r5.ebuild,v 1.1 2007/01/29 19:27:22 zzam Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+# still rely on hotplug (need to fix that), but now we implement coldplug
+
+DEPEND="sys-apps/hotplug-base
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="!sys-apps/coldplug"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.11.14"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+ epatch ${FILESDIR}/${P}-netif-rename-busywait.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "295a9b7bdc8bdb239f8860d14af761b0" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/ata_id \
+ extras/cdrom_id \
+ extras/dasd_id \
+ extras/edd_id \
+ extras/firmware \
+ extras/floppy \
+ extras/path_id \
+ extras/run_directory \
+ extras/scsi_id \
+ extras/usb_id \
+ extras/volume_id \
+ extras/rule_generator"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ echo "get_libdir = $(get_libdir)"
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS_COMPILE=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo || die "Required binary not installed properly"
+ dobin udevtest || die "Required binary not installed properly"
+ dobin udevmonitor || die "Required binary not installed properly"
+ into /
+ dosbin udevd || die "Required binary not installed properly"
+ dosbin udevstart || die "Required binary not installed properly"
+ dosbin udevtrigger || die "Required binary not installed properly"
+ dosbin udevcontrol || die "Required binary not installed properly"
+ dosbin udevsettle || die "Required binary not installed properly"
+
+ # Helpers
+ exeinto /lib/udev
+ doexe extras/run_directory/udev_run_devd || die "Required helper not installed properly"
+ doexe extras/run_directory/udev_run_hotplugd || die "Required helper not installed properly"
+ doexe extras/ata_id/ata_id || die "Required helper not installed properly"
+ doexe extras/volume_id/vol_id || die "Required helper not installed properly"
+ doexe extras/scsi_id/scsi_id || die "Required helper not installed properly"
+ doexe extras/usb_id/usb_id || die "Required helper not installed properly"
+ doexe extras/path_id/path_id || die "Required helper not installed properly"
+ doexe extras/cdrom_id/cdrom_id || die "Required helper not installed properly"
+ doexe extras/dasd_id/dasd_id || die "Required helper not installed properly"
+ doexe extras/edd_id/edd_id || die "Required helper not installed properly"
+ doexe extras/rule_generator/write_cd_rules || die "Required helper not installed properly"
+ doexe extras/rule_generator/write_net_rules || die "Required helper not installed properly"
+ doexe extras/rule_generator/rule_generator.functions || die "Required helper not installed properly"
+ keepdir /lib/udev/state
+ keepdir /lib/udev/devices
+
+ # vol_id library (needed by mount and HAL)
+ dolib extras/volume_id/lib/*.a extras/volume_id/lib/*.so*
+ # move the .a files to /usr/lib
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
+
+ # handle static linking bug #4411
+ gen_usr_ldscript libvolume_id.so
+
+ # save pkgconfig info
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins extras/volume_id/lib/*.pc
+
+ #exeinto /etc/udev/scripts
+ exeinto /lib/udev
+ #doexe extras/ide-devfs.sh
+ #doexe extras/scsi-devfs.sh
+ #doexe extras/raid-devfs.sh
+ doexe extras/floppy/create_floppy_devices || die "Required binary not installed properly"
+ doexe extras/firmware/firmware.sh || die "Required binary not installed properly"
+ doexe ${FILESDIR}/net.sh || die "Required binary not installed properly"
+ doexe ${FILESDIR}/seq_node.sh || die "Required binary not installed properly"
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_081 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ newins etc/udev/gentoo/udev.rules 50-udev.rules
+ newins ${FILESDIR}/udev.rules-104-r4 50-udev.rules
+ newins ${FILESDIR}/05-udev-early.rules-104-r5 05-udev-early.rules
+ doins ${FILESDIR}/95-net.rules
+ # Use upstream's persistent rules for devices
+ doins etc/udev/rules.d/60-*.rules
+ doins extras/rule_generator/75-*.rules || die "rules not installed properly"
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up the /etc/dev.d directory tree
+ keepdir /etc/dev.d
+
+ # all of the man pages
+ doman *.7
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/dasd_id/dasd_id.8
+ doman extras/cdrom_id/cdrom_id.8
+ # create a extra symlink for udevcontrol
+ dosym udevd.8 /usr/share/man/man8/udevcontrol.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-104-r5.sh udev-start.sh
+ newins "${FILESDIR}"/udev-stop-104-r3.sh udev-stop.sh
+
+ # Insert udev-version number into udev-rcscript addon
+ sed -e "s/@@UDEV_VERSION@@/${PV}/" \
+ -i "${D}"/lib/rcscripts/addons/udev-start.sh \
+ -i "${D}"/lib/rcscripts/addons/udev-stop.sh
+
+ # needed to compile latest Hal
+ insinto /usr/include
+ doins extras/volume_id/lib/libvolume_id.h
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+
+}
+
+pkg_preinst() {
+ if [[ -d ${ROOT}/lib/udev-state ]] ; then
+ mv -f "${ROOT}"/lib/udev-state/* "${D}"/lib/udev/state/
+ rm -r "${ROOT}"/lib/udev-state
+ fi
+
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/10-udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/10-udev.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [ -f "${ROOT}/etc/init.d/coldplug" ]
+ then
+ coldplug_stale="1"
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ if [[ -n $(pidof udevd) ]] ; then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+ fi
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+
+ if [[ ${coldplug_stale} == "1" ]] ; then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ # delete 40-scsi-hotplug.rules - all integrated in 50-udev.rules
+ if has_version "=sys-fs/udev-103-r3"; then
+ if [[ -e "${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules" ]]
+ then
+ ewarn "Deleting stray 40-scsi-hotplug.rules"
+ ewarn "installed by sys-fs/udev-103-r3"
+ rm -f ${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules
+ fi
+ fi
+
+ # Removing some device-nodes we thought we need some time ago
+ if [[ -d "${ROOT}"/lib/udev/devices ]]; then
+ rm -f "${ROOT}"/lib/udev/devices/{null,zero,console,urandom}
+ fi
+
+ # Removing some old file
+ if has_version "<sys-fs/udev-104-r5"; then
+ rm -f "${ROOT}"/etc/dev.d/net/hotplug.dev
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net
+ fi
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}