summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-17 00:43:42 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-17 00:43:42 +0000
commit55378007052871bd3d054005eb3d3101f6509a23 (patch)
tree3e1a901c8eff422301e1d1606a5707d2a887f60a /sys-fs/vhba
parentAdd eaclocal to src_prepare. Should fix bug #473096. Thanks to Mark Zhitomirski. (diff)
downloadgentoo-2-55378007052871bd3d054005eb3d3101f6509a23.tar.gz
gentoo-2-55378007052871bd3d054005eb3d3101f6509a23.tar.bz2
gentoo-2-55378007052871bd3d054005eb3d3101f6509a23.zip
Version bump, now supports O_NONBLOCK (bug #472784, thanks to Henrik Stokseth and Rafał Mużyło). Remove old.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/ChangeLog12
-rw-r--r--sys-fs/vhba/files/vhba-20110915-3.4-kmap_atomic.patch100
-rw-r--r--sys-fs/vhba/vhba-20130607.ebuild (renamed from sys-fs/vhba/vhba-20110915.ebuild)24
3 files changed, 21 insertions, 115 deletions
diff --git a/sys-fs/vhba/ChangeLog b/sys-fs/vhba/ChangeLog
index f32f0088721a..fb79934823b5 100644
--- a/sys-fs/vhba/ChangeLog
+++ b/sys-fs/vhba/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/vhba
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.43 2012/12/03 02:23:12 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.44 2013/06/17 00:43:42 tetromino Exp $
+
+*vhba-20130607 (17 Jun 2013)
+
+ 17 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -vhba-20110915.ebuild, +vhba-20130607.ebuild,
+ -files/vhba-20110915-3.4-kmap_atomic.patch:
+ Version bump, now supports O_NONBLOCK (bug #472784, thanks to Henrik Stokseth
+ and Rafał Mużyło). Remove old.
03 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> vhba-20110915.ebuild,
vhba-20120422-r1.ebuild:
diff --git a/sys-fs/vhba/files/vhba-20110915-3.4-kmap_atomic.patch b/sys-fs/vhba/files/vhba-20110915-3.4-kmap_atomic.patch
deleted file mode 100644
index 43bd58dacfaa..000000000000
--- a/sys-fs/vhba/files/vhba-20110915-3.4-kmap_atomic.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-From 0e051e8655c1d68d748d4b6976261aee7d2c248a Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Sat, 21 Apr 2012 14:16:59 -0400
-Subject: [PATCH] VHBA: 2-argument k[un]map_atomic is deprecated in >=3.4-rc1
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The 1-argument form of k[un]map_atomic was introduced in 2.6.37-rc1, and
-the old 2-argument form is deprecated in 3.4-rc1 and higher. As a
-result, building vhba for a 3.4-rc* kernel that has
-CONFIG_ENABLE_WARN_DEPRECATED fails:
-
-/tmp/cdemu/vhba-module/vhba.c: In function ‘do_request’:
-/tmp/cdemu/vhba-module/vhba.c:487:33: error: ‘kmap_atomic_deprecated’ is
-deprecated (declared at include/linux/highmem.h:125)
-[-Werror=deprecated-declarations]
-/tmp/cdemu/vhba-module/vhba.c:492:1: error: ‘__kunmap_atomic_deprecated’
-is deprecated (declared at include/linux/highmem.h:135)
-[-Werror=deprecated-declarations]
-/tmp/cdemu/vhba-module/vhba.c: In function ‘do_response’:
-/tmp/cdemu/vhba-module/vhba.c:570:33: error: ‘kmap_atomic_deprecated’ is
-deprecated (declared at include/linux/highmem.h:125)
-[-Werror=deprecated-declarations]
-/tmp/cdemu/vhba-module/vhba.c:575:1: error: ‘__kunmap_atomic_deprecated’
-is deprecated (declared at include/linux/highmem.h:135)
-[-Werror=deprecated-declarations]
-cc1: all warnings being treated as errors
-
-To work around this problem, add vhba_k[un]map_atomic wrappers that
-default to the 1-argument form of k[un]map_atomic for 2.6.37 and newer,
-and to the old 2-argument form for older kernels.
----
- vhba-module/vhba.c | 23 +++++++++++++++++------
- 1 files changed, 17 insertions(+), 6 deletions(-)
-
-diff --git a/vhba-module/vhba.c b/vhba-module/vhba.c
-index 8937b94..a36fd59 100644
---- a/vhba-module/vhba.c
-+++ b/vhba-module/vhba.c
-@@ -27,6 +27,7 @@
- #include <linux/miscdevice.h>
- #include <linux/poll.h>
- #include <linux/slab.h>
-+#include <linux/version.h>
- #ifdef CONFIG_COMPAT
- #include <linux/compat.h>
- #endif
-@@ -64,6 +65,16 @@ MODULE_LICENSE("GPL");
- #define DATA_TO_DEVICE(dir) ((dir) == DMA_TO_DEVICE || (dir) == DMA_BIDIRECTIONAL)
- #define DATA_FROM_DEVICE(dir) ((dir) == DMA_FROM_DEVICE || (dir) == DMA_BIDIRECTIONAL)
-
-+/* 1-argument form of k[un]map_atomic was introduced in 2.6.37-rc1;
-+ 2-argument form was deprecated in 3.4-rc1 */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 37)
-+#define vhba_kmap_atomic kmap_atomic
-+#define vhba_kunmap_atomic kunmap_atomic
-+#else
-+#define vhba_kmap_atomic(page) kmap_atomic(page, KM_USER0)
-+#define vhba_kunmap_atomic(page) kunmap_atomic(page, KM_USER0)
-+#endif
-+
- enum vhba_req_state {
- VHBA_REQ_FREE,
- VHBA_REQ_PENDING,
-@@ -473,12 +484,12 @@ static ssize_t do_request(struct scsi_cmnd *cmd, char __user *buf, size_t buf_le
- size_t len = sg[i].length;
-
- #ifdef KAT_SCATTERLIST_HAS_PAGE_LINK
-- kaddr = kmap_atomic(sg_page(&sg[i]), KM_USER0);
-+ kaddr = vhba_kmap_atomic(sg_page(&sg[i]));
- #else
-- kaddr = kmap_atomic(sg[i].page, KM_USER0);
-+ kaddr = vhba_kmap_atomic(sg[i].page);
- #endif
- memcpy(kbuf, kaddr + sg[i].offset, len);
-- kunmap_atomic(kaddr, KM_USER0);
-+ vhba_kunmap_atomic(kaddr);
-
- if (copy_to_user(uaddr, kbuf, len)) {
- if (kbuf != buf_stack)
-@@ -556,12 +567,12 @@ static ssize_t do_response(struct scsi_cmnd *cmd, const char __user *buf, size_t
- uaddr += len;
-
- #ifdef KAT_SCATTERLIST_HAS_PAGE_LINK
-- kaddr = kmap_atomic(sg_page(&sg[i]), KM_USER0);
-+ kaddr = vhba_kmap_atomic(sg_page(&sg[i]));
- #else
-- kaddr = kmap_atomic(sg[i].page, KM_USER0);
-+ kaddr = vhba_kmap_atomic(sg[i].page);
- #endif
- memcpy(kaddr + sg[i].offset, kbuf, len);
-- kunmap_atomic(kaddr, KM_USER0);
-+ vhba_kunmap_atomic(kaddr);
-
- to_read -= len;
- if (to_read == 0)
---
-1.7.8.5
-
diff --git a/sys-fs/vhba/vhba-20110915.ebuild b/sys-fs/vhba/vhba-20130607.ebuild
index c0a0fc91eb56..97273ed1aee0 100644
--- a/sys-fs/vhba/vhba-20110915.ebuild
+++ b/sys-fs/vhba/vhba-20130607.ebuild
@@ -1,27 +1,28 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-20110915.ebuild,v 1.10 2012/12/03 02:23:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-20130607.ebuild,v 1.1 2013/06/17 00:43:42 tetromino Exp $
-EAPI="4"
+EAPI="5"
-inherit eutils linux-mod user udev
+inherit linux-mod user udev
MY_P=vhba-module-${PV}
DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
HOMEPAGE="http://cdemu.org"
-SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~hppa x86"
+KEYWORDS="~amd64 ~hppa ~x86"
IUSE=""
RDEPEND="virtual/udev"
-DEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
S=${WORKDIR}/${MY_P}
MODULE_NAMES="vhba(block:${S})"
-BUILD_TARGETS=all
+BUILD_TARGETS=modules
pkg_setup() {
CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
@@ -33,11 +34,8 @@ pkg_setup() {
}
src_prepare() {
- # Build failure with >=3.4-rc1 and CONFIG_ENABLE_WARN_DEPRECATED, #411459
- epatch "${FILESDIR}/${P}-3.4-kmap_atomic.patch"
# Avoid "make jobserver unavailable" warning and -Werror problems
- sed -e 's:\t$(KMAKE):\t+$(KMAKE):g' \
- -e '/EXTRA_CFLAGS/s/-Werror$/-Wall/' \
+ sed -e '/ccflags/s/-Werror$/-Wall/' \
-i Makefile || die "sed failed"
}