summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-09-11 14:29:19 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-09-11 14:29:19 +0000
commit1540eb98225a5c90020fb3fa93506ea0e9c6627e (patch)
treefb67edc99e263bd579cc6964b933eed217723b1b /sys-fs
parentStable on amd64 wrt security Bug #139976. (diff)
downloadgentoo-2-1540eb98225a5c90020fb3fa93506ea0e9c6627e.tar.gz
gentoo-2-1540eb98225a5c90020fb3fa93506ea0e9c6627e.tar.bz2
gentoo-2-1540eb98225a5c90020fb3fa93506ea0e9c6627e.zip
version bump
(Portage version: 2.1.1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.0_rc13
-rw-r--r--sys-fs/fuse/fuse-2.6.0_rc1.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 6ae3c47ff8b4..7cd935d8ceb7 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.56 2006/07/24 06:30:10 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.57 2006/09/11 14:29:19 genstef Exp $
+
+*fuse-2.6.0_rc1 (11 Sep 2006)
+
+ 11 Sep 2006; Stefan Schweizer <genstef@gentoo.org>
+ -fuse-2.6.0_pre3.ebuild, +fuse-2.6.0_rc1.ebuild:
+ version bump
*fuse-2.6.0_pre3 (24 Jul 2006)
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.0_rc1 b/sys-fs/fuse/files/digest-fuse-2.6.0_rc1
new file mode 100644
index 000000000000..af51a510c05f
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.6.0_rc1
@@ -0,0 +1,3 @@
+MD5 b6d09a3fe8a1b09162cbdffeb1091f52 fuse-2.6.0-rc1.tar.gz 435861
+RMD160 c872c7835daf6b6f85342f5f05f36bb8c2f29aeb fuse-2.6.0-rc1.tar.gz 435861
+SHA256 f7046379088ff6bbceaaf989a9ec838f7bf8d7fd7833ffdecdc8a32dc5bd9dce fuse-2.6.0-rc1.tar.gz 435861
diff --git a/sys-fs/fuse/fuse-2.6.0_rc1.ebuild b/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
new file mode 100644
index 000000000000..df5dddac2cd5
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.1 2006/09/11 14:29:19 genstef Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
+BUILD_TARGETS="all"
+ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
+
+pkg_setup() {
+ use kernel_linux && linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ einfo "Preparing fuse userland"
+ econf --disable-kernel-module --disable-example || \
+ die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux; then
+ sed -i -e 's/.*depmod.*//g' ${S}/kernel/Makefile.in
+ convert_to_m ${S}/kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
+ README.NFS NEWS doc/how-fuse-works
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux; then
+ linux-mod_src_install
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}