summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-12-18 17:32:10 +0000
committerThomas Sachau <tommy@gentoo.org>2009-12-18 17:32:10 +0000
commit2772b2bdf60f0dab768df656640b12e41b49129c (patch)
tree70feefbf096e1806d0e9100c4627f868e5175445 /sys-fs
parentStable for HPPA (bug #297297). (diff)
downloadgentoo-2-2772b2bdf60f0dab768df656640b12e41b49129c.tar.gz
gentoo-2-2772b2bdf60f0dab768df656640b12e41b49129c.tar.bz2
gentoo-2-2772b2bdf60f0dab768df656640b12e41b49129c.zip
Bump to latest version, include support for 2.6.32
(Portage version: 2.2_rc60-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs2/ChangeLog9
-rw-r--r--sys-fs/aufs2/aufs2-0_p20091214.ebuild89
-rw-r--r--sys-fs/aufs2/files/aufs2-base-32.patch81
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-32.patch182
-rw-r--r--sys-fs/aufs2/files/utils-Makefile.patch18
5 files changed, 360 insertions, 19 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index 9e8f353a693f..73c4d94e8e9e 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.12 2009/11/27 14:14:40 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.13 2009/12/18 17:32:10 tommy Exp $
+
+*aufs2-0_p20091214 (18 Dec 2009)
+
+ 18 Dec 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +aufs2-0_p20091214.ebuild, +files/aufs2-base-32.patch,
+ +files/aufs2-standalone-32.patch, -files/utils-Makefile.patch:
+ Bump to latest version, include support for 2.6.32
27 Nov 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
-aufs2-0_p20090916.ebuild, aufs2-0_p20090916-r1.ebuild:
diff --git a/sys-fs/aufs2/aufs2-0_p20091214.ebuild b/sys-fs/aufs2/aufs2-0_p20091214.ebuild
new file mode 100644
index 000000000000..7d1f1b55c4d1
--- /dev/null
+++ b/sys-fs/aufs2/aufs2-0_p20091214.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20091214.ebuild,v 1.1 2009/12/18 17:32:10 tommy Exp $
+
+EAPI="2"
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug inotify kernel-patch nfs ramfs"
+
+DEPEND="dev-util/git"
+RDEPEND="!sys-fs/aufs"
+
+S=${WORKDIR}/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ get_version
+ kernel_is lt 2 6 27 && die "kernel too old"
+ kernel_is gt 2 6 32 && die "kernel too new"
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null
+ epatch "${FILESDIR}"/aufs2-{base,standalone}-${KV_PATCH}.patch
+ elog "You need to compile your kernel with the applied patch"
+ elog "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/aufs2-base-${KV_PATCH}.patch and"
+ eerror "${FILESDIR}/aufs2-standalone-${KV_PATCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ local branch=origin/aufs2-${KV_PATCH}
+ if [[ $KV_PATCH == 33 ]] ; then
+ branch=origin/aufs2
+ fi
+ git checkout -q $branch || die
+ if ! use debug; then
+ sed -i "s:DEBUG = y:DEBUG =:g" config.mk || die
+ fi
+ if use inotify; then
+ sed -i "s:HINOTIFY =:HINOTIFY = y:g" config.mk || die
+ fi
+ if use ramfs; then
+ sed -i "s:RAMFS =:RAMFS = y:g" config.mk || die
+ fi
+
+ cd "${WORKDIR}"/${PN}-util
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+}
+
+src_compile() {
+ local myargs="" ARCH=x86
+ use nfs && myargs="CONFIG_EXPORTFS=y CONFIG_AUFS_EXPORT=y "
+ use nfs && use amd64 && myargs+="CONFIG_AUFS_INO_T_64=y"
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m ${myargs} KDIR=${KV_DIR} || die
+ cd "${WORKDIR}"/${PN}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include || die
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README || die
+ docinto design
+ dodoc design/*.txt || die
+ cd "${WORKDIR}"/${PN}-util
+ emake DESTDIR="${D}" install || die
+ docinto
+ newdoc README README-utils || die
+}
diff --git a/sys-fs/aufs2/files/aufs2-base-32.patch b/sys-fs/aufs2/files/aufs2-base-32.patch
new file mode 100644
index 000000000000..b8db42f2ac1c
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-base-32.patch
@@ -0,0 +1,81 @@
+aufs2 base patch for linux-2.6.32
+
+diff --git a/fs/namei.c b/fs/namei.c
+index d11f404..7d28f56 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -1219,7 +1219,7 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ int err;
+
+@@ -1229,7 +1229,7 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+diff --git a/fs/splice.c b/fs/splice.c
+index 7394e9e..77184f0 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1051,8 +1051,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
+ loff_t *, size_t, unsigned int);
+@@ -1078,9 +1078,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ ssize_t (*splice_read)(struct file *, loff_t *,
+ struct pipe_inode_info *, size_t, unsigned int);
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index ec0f607..1438153 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -75,6 +75,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
+ extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
+ extern void release_open_intent(struct nameidata *);
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+ extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
+
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 18e7c7c..8393b5c 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -82,4 +82,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
+ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
+ splice_direct_actor *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
diff --git a/sys-fs/aufs2/files/aufs2-standalone-32.patch b/sys-fs/aufs2/files/aufs2-standalone-32.patch
new file mode 100644
index 000000000000..1780b91e0616
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-32.patch
@@ -0,0 +1,182 @@
+aufs2 standalone patch for linux-2.6.32
+
+diff --git a/fs/namei.c b/fs/namei.c
+index 7d28f56..0f6117c 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -350,6 +350,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1228,6 +1229,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+ return ERR_PTR(err);
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+ int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+@@ -1250,6 +1252,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index bdc3cb4..a2cadcf 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -39,6 +39,7 @@
+
+ /* spinlock for vfsmount related operations, inplace of dcache_lock */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
++EXPORT_SYMBOL(vfsmount_lock);
+
+ static int event;
+ static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/open.c b/fs/open.c
+index 4f01e06..ef09031 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -223,6 +223,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return ret;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index 77184f0..8479d95 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1074,6 +1074,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+@@ -1099,6 +1100,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+
+ return splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index 6cf8fd2..008e0d8 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -514,6 +514,7 @@ found:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
+index b85e61b..a23fad4 100644
+--- a/security/integrity/ima/ima_main.c
++++ b/security/integrity/ima/ima_main.c
+@@ -324,6 +324,7 @@ int ima_file_mmap(struct file *file, unsigned long prot)
+ MAY_EXEC, FILE_MMAP);
+ return 0;
+ }
++EXPORT_SYMBOL(ima_file_mmap);
+
+ /**
+ * ima_bprm_check - based on policy, collect/store measurement.
+diff --git a/security/security.c b/security/security.c
+index c4c6732..854d15c 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -386,6 +386,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
+ return 0;
+ return security_ops->path_mkdir(path, dentry, mode);
+ }
++EXPORT_SYMBOL(security_path_mkdir);
+
+ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ {
+@@ -393,6 +394,7 @@ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_rmdir(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_rmdir);
+
+ int security_path_unlink(struct path *path, struct dentry *dentry)
+ {
+@@ -400,6 +402,7 @@ int security_path_unlink(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_unlink(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_unlink);
+
+ int security_path_symlink(struct path *path, struct dentry *dentry,
+ const char *old_name)
+@@ -408,6 +411,7 @@ int security_path_symlink(struct path *path, struct dentry *dentry,
+ return 0;
+ return security_ops->path_symlink(path, dentry, old_name);
+ }
++EXPORT_SYMBOL(security_path_symlink);
+
+ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ struct dentry *new_dentry)
+@@ -416,6 +420,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ return 0;
+ return security_ops->path_link(old_dentry, new_dir, new_dentry);
+ }
++EXPORT_SYMBOL(security_path_link);
+
+ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ struct path *new_dir, struct dentry *new_dentry)
+@@ -426,6 +431,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ return security_ops->path_rename(old_dir, old_dentry, new_dir,
+ new_dentry);
+ }
++EXPORT_SYMBOL(security_path_rename);
+
+ int security_path_truncate(struct path *path, loff_t length,
+ unsigned int time_attrs)
+@@ -434,6 +440,7 @@ int security_path_truncate(struct path *path, loff_t length,
+ return 0;
+ return security_ops->path_truncate(path, length, time_attrs);
+ }
++EXPORT_SYMBOL(security_path_truncate);
+ #endif
+
+ int security_inode_create(struct inode *dir, struct dentry *dentry, int mode)
+@@ -505,6 +512,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -519,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
+@@ -619,6 +628,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
diff --git a/sys-fs/aufs2/files/utils-Makefile.patch b/sys-fs/aufs2/files/utils-Makefile.patch
deleted file mode 100644
index b989fdab2770..000000000000
--- a/sys-fs/aufs2/files/utils-Makefile.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile 2009-05-10 19:23:32.000000000 +0200
-+++ Makefile.new 2009-05-10 19:23:49.000000000 +0200
-@@ -21,7 +21,6 @@
-
- CFLAGS += -I${KDIR}/include
- CFLAGS += -O -Wall
--LDFLAGS += -static -s
-
- Cmd = umount.aufs auchk #aubrsync
- Etc = etc_default_aufs
-@@ -55,6 +54,7 @@
- install_etc: File = etc_default_aufs
- install_etc: Tgt = ${DESTDIR}/etc/default/aufs
- install_sbin install_ubin install_etc: ${File}
-+ mkdir -p ${Tgt}
- install -m 755 -o root -g root -p ${File} ${Tgt}
- install: install_sbin install_ubin install_etc
-