summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2004-12-15 23:14:21 +0000
committerDaniel Drake <dsd@gentoo.org>2004-12-15 23:14:21 +0000
commit25e6807404980b55eefbf715230f5e42f13bdff0 (patch)
tree026515449c824a3aa4e5260f1260294c01a72a54 /sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild
parentsecurity bump, x86 stable (diff)
downloadgentoo-2-25e6807404980b55eefbf715230f5e42f13bdff0.tar.gz
gentoo-2-25e6807404980b55eefbf715230f5e42f13bdff0.tar.bz2
gentoo-2-25e6807404980b55eefbf715230f5e42f13bdff0.zip
Fix oom-killer, add IGMP and scm_send security fixes, plus a gazillion sparc fixes thanks to eradicator
Diffstat (limited to 'sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild')
-rw-r--r--sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild
new file mode 100644
index 000000000000..134ee0e64e54
--- /dev/null
+++ b/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-dev-sources/gentoo-dev-sources-2.6.9-r10.ebuild,v 1.1 2004/12/15 23:14:21 dsd Exp $
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+detect_arch
+
+#version of gentoo patchset
+GPV="9.11"
+GPV_SRC="mirror://gentoo/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}-base.tar.bz2
+ mirror://gentoo/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}-extras.tar.bz2"
+
+KEYWORDS="~x86 ~sparc"
+
+HOMEPAGE="http://dev.gentoo.org/~dsd/gentoo-dev-sources"
+
+UNIPATCH_LIST="${DISTDIR}/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}-base.tar.bz2
+ ${DISTDIR}/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}-extras.tar.bz2"
+UNIPATCH_DOCS="${WORKDIR}/patches/genpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}/0000_README"
+
+DESCRIPTION="Full sources including the gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GPV_SRC} ${ARCH_URI}"
+
+DEPEND="${DEPEND} >=dev-libs/ucl-1"
+
+IUSE="ultra1"
+use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 1399_sparc-U1-hme-lockup.patch"
+use sparc && UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 4905_speakup-20041020.patch"
+
+pkg_postinst() {
+ postinst_sources
+
+ echo
+
+ if [ "${ARCH}" = "sparc" ]; then
+ if [ x"`cat /proc/openprom/name 2>/dev/null`" \
+ = x"'SUNW,Ultra-1'" ]; then
+ einfo "For users with an Enterprise model Ultra 1 using the HME"
+ einfo "network interface, please emerge the kernel using the"
+ einfo "following command: USE=ultra1 emerge ${PN}"
+ fi
+ fi
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}