summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-12-24 18:23:50 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-12-24 18:23:50 +0000
commit0a50b4059624c198fdf50beb79af66647bb4cdac (patch)
treeaa4f27b11985f6839bd4e121440f7cdb7f05e984 /sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild
parentDEPEND update closes bug #75349. (Manifest recommit) (diff)
downloadgentoo-2-0a50b4059624c198fdf50beb79af66647bb4cdac.tar.gz
gentoo-2-0a50b4059624c198fdf50beb79af66647bb4cdac.tar.bz2
gentoo-2-0a50b4059624c198fdf50beb79af66647bb4cdac.zip
Security bump; bugs #72452, #74384, #74392, #74464.
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild
new file mode 100644
index 000000000000..68b38553d6a8
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.25-r14.ebuild,v 1.1 2004/12/24 18:23:50 plasmaroo Exp $
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+KEYWORDS="x86 -ppc"
+IUSE=''
+
+UNIPATCH_STRICTORDER='Y'
+UNIPATCH_LIST="
+ ${DISTDIR}/${P}.patch.bz2
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0109.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0133.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0177.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0178.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0181.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0394.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0427.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0495.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0497.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0535.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-0685.patch
+ ${FILESDIR}/${PN}-2.4.FPULockup-53804.patch
+ ${FILESDIR}/${PN}-2.4.cmdlineLeak.patch
+ ${FILESDIR}/${PN}-2.4.XDRWrapFix.patch
+ ${FILESDIR}/${PN}-2.4.binfmt_elf.patch
+ ${FILESDIR}/${PN}-2.4.smbfs.patch
+ ${DISTDIR}/linux-2.4.26-CAN-2004-0415.patch
+ ${DISTDIR}/${PN}-2.4.22-CAN-2004-0814.patch
+ ${FILESDIR}/${PN}-2.4.AF_UNIX.patch
+ ${FILESDIR}/${PN}-2.4.binfmt_a.out.patch
+ ${FILESDIR}/${PN}-2.4.vma.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-1016.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-1056.patch
+ ${FILESDIR}/${PN}-2.4.CAN-2004-1137.patch"
+
+DESCRIPTION="Full sources including the gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} http://dev.gentoo.org/~livewire/${P}.patch.bz2
+ http://dev.gentoo.org/~plasmaroo/patches/kernel/misc/security/linux-2.4.26-CAN-2004-0415.patch
+ http://dev.gentoo.org/~plasmaroo/patches/kernel/misc/security/${PN}-2.4.22-CAN-2004-0814.patch"
+