summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2005-02-24 19:42:09 +0000
committerJoshua Kinard <kumba@gentoo.org>2005-02-24 19:42:09 +0000
commitb949909f4a534d670f9ae157272abd1bd67c5c84 (patch)
tree04d22790733eefd9013fd8d2d37e0f0eff72b2e9 /sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild
parentTo stable on x86 and sparc (diff)
downloadgentoo-2-b949909f4a534d670f9ae157272abd1bd67c5c84.tar.gz
gentoo-2-b949909f4a534d670f9ae157272abd1bd67c5c84.tar.bz2
gentoo-2-b949909f4a534d670f9ae157272abd1bd67c5c84.zip
Forgot to add eutils when using epatch.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild')
-rw-r--r--sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild b/sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild
new file mode 100644
index 000000000000..4501f3221963
--- /dev/null
+++ b/sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-headers/mips-headers-2.4.28-r1.ebuild,v 1.1 2005/02/24 19:42:09 kumba Exp $
+
+ETYPE="headers"
+inherit kernel eutils
+
+OKV="${PV/_/-}"
+CVSDATE="20050105"
+EXTRAVERSION="-mipscvs-${CVSDATE}"
+KV="${OKV}${EXTRAVERSION}"
+S="${WORKDIR}/linux-${KV}"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 1) linux sources from kernel.org
+# 2) linux-mips.org CVS snapshot diff from 25 Aug 2003
+# 3) patch to fix arch/mips[64]/Makefile to pass appropriate CFLAGS
+
+DESCRIPTION="Linux-Mips CVS headers for MIPS-based machines"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/mipscvs-${OKV}-${CVSDATE}.diff.bz2"
+HOMEPAGE="http://www.linux-mips.org/"
+SLOT="0"
+PROVIDE="virtual/os-headers"
+KEYWORDS="-* ~mips"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/linux-${OKV} ${S}
+ cd ${S}
+
+ # Update the vanilla sources with linux-mips CVS changes
+ epatch ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff
+
+ kernel_universal_unpack
+}
+
+src_install() {
+
+ # Do normal src_install stuff
+ kernel_src_install
+
+ # If this is mips64, then we need asm-mips64 stuff too
+ if [ "${PROFILE_ARCH}" = "mips64" ]; then
+ dodir /usr/include/asm-mips64
+ cp -ax ${S}/include/asm-mips64/* ${D}/usr/include/asm-mips64
+ fi
+}
+
+pkg_postinst() {
+ kernel_pkg_postinst
+
+ einfo "Kernel headers are usually only used when recompiling glibc, as such, following the installation"
+ einfo "of newer headers, it is advised that you re-merge glibc as follows:"
+ einfo "emerge glibc"
+ einfo "Failure to do so will cause glibc to not make use of newer features present in the updated kernel"
+ einfo "headers."
+}