summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-04-23 15:39:22 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-04-23 15:39:22 +0000
commitac3bc46648a1bc4d1b136309de41739995c93325 (patch)
treec27db3735cd31935e50bee453985a96f1009cf32 /sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild
parentMarked ~hppa (bug #218436). (diff)
downloadgentoo-2-ac3bc46648a1bc4d1b136309de41739995c93325.tar.gz
gentoo-2-ac3bc46648a1bc4d1b136309de41739995c93325.tar.bz2
gentoo-2-ac3bc46648a1bc4d1b136309de41739995c93325.zip
Version and revision bumps: new TuxOnIce version - 3.0-rc7, new genpatches versions.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild')
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild
new file mode 100644
index 000000000000..a577293a8a6d
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r12.ebuild,v 1.1 2008/04/23 15:39:22 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches http://www.tuxonice.net"
+
+TUXONICE_VERSION="3.0-rc7"
+TUXONICE_TARGET="2.6.23.16"
+TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}"
+TUXONICE_URI="http://www.tuxonice.net/downloads/all/${TUXONICE_SRC}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.patch.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-0.7.2
+ >=sys-power/hibernate-script-1.97"
+
+K_EXTRAEINFO="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}