summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-12 06:43:06 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-12 06:43:06 +0000
commit603356e01b96473984ecd109c455313c945eea76 (patch)
treefba61eb7df225a4926cb83d6d4687f29c84633b2 /sys-kernel
parentblah (diff)
downloadgentoo-2-603356e01b96473984ecd109c455313c945eea76.tar.gz
gentoo-2-603356e01b96473984ecd109c455313c945eea76.tar.bz2
gentoo-2-603356e01b96473984ecd109c455313c945eea76.zip
new version thanks livewire
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog21
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre42
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.20_pre4.ebuild67
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 1adceec1986f..ecc6a5825d41 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,6 +1,25 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.12 2003/01/06 04:20:16 viz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.13 2003/01/12 06:43:06 lostlogic Exp $
+
+*xfs-sources-2.4.20_pre4 (10 Jan 2003)
+
+ 10 Jan 2003; Bob Johnson <livewire_@ameritech.net>:
+ This is the first patchset under new management. Thanks to viz
+ for getting us up to _pre3.
+
+ Committed by lostlogic ;-)
+
+ Changes from _pre3
+ * Move to new IDE core.
+ * 3c509 Fix
+ * ext3-data-journal-fix
+ * aic7xx drivers fix
+ * Drop supermount incompatible with new IDE
+
+ Ebuild changes:
+ * Snag bits from lolo-sources to talk about what goes on
+ in the unpack stage.
*xfs-sources-2.4.20_pre3 (6 Jan 2003)
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre4 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre4
new file mode 100644
index 000000000000..e281d553d71b
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre4
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 a394636b491e09ac18dd6f88b9ac9b50 patches-2.4.20-xfs_pre4.tar.bz2 2837209
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre4.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre4.ebuild
new file mode 100644
index 000000000000..6494f17cfe1c
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre4.ebuild,v 1.1 2003/01/12 06:43:06 lostlogic Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-xfs_pre4
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}