summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-30 17:56:49 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-30 17:56:49 +0000
commit72caaa6edd211f88d8f5165b37ce2806f1c3e979 (patch)
treeb557e75cbee7cb1b47164d8c1dc7b1675ba83ed0 /sys-kernel
parentSome cleanup, add support for postgres, add mh-utils, address Bug 22864 (Mani... (diff)
downloadgentoo-2-72caaa6edd211f88d8f5165b37ce2806f1c3e979.tar.gz
gentoo-2-72caaa6edd211f88d8f5165b37ce2806f1c3e979.tar.bz2
gentoo-2-72caaa6edd211f88d8f5165b37ce2806f1c3e979.zip
Added a patch for the IPTables RDoS vulnerability; bug #55694.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/aa-sources/ChangeLog6
-rw-r--r--sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild4
-rw-r--r--sys-kernel/aa-sources/files/aa-sources-2.6.5.IPTables-RDoS.patch11
3 files changed, 18 insertions, 3 deletions
diff --git a/sys-kernel/aa-sources/ChangeLog b/sys-kernel/aa-sources/ChangeLog
index 837609bd2715..2af8e1030fef 100644
--- a/sys-kernel/aa-sources/ChangeLog
+++ b/sys-kernel/aa-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/aa-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/ChangeLog,v 1.42 2004/06/29 17:10:53 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/ChangeLog,v 1.43 2004/06/30 17:56:49 plasmaroo Exp $
+
+ 30 Jun 2004; <plasmaroo@gentoo.org> aa-sources-2.6.5-r5.ebuild,
+ +files/aa-sources-2.6.5.IPTables-RDoS.patch:
+ Added a patch for the IPTables RDoS vulnerability; bug #55694.
29 Jun 2004; <plasmaroo@gentoo.org> aa-sources-2.4.23-r2.ebuild,
+files/aa-sources-2.4.23.CAN-2004-0495.patch,
diff --git a/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild b/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild
index 23ca268068b2..34577d4161c2 100644
--- a/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild
+++ b/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild,v 1.5 2004/06/24 22:55:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/aa-sources/aa-sources-2.6.5-r5.ebuild,v 1.6 2004/06/30 17:56:49 plasmaroo Exp $
-UNIPATCH_LIST="${DISTDIR}/${KV}.bz2 ${FILESDIR}/${P}.CAN-2004-0075.patch ${FILESDIR}/${P}.CAN-2004-0228.patch ${FILESDIR}/${P}.CAN-2004-0229.patch ${FILESDIR}/${P}.CAN-2004-0427.patch ${FILESDIR}/${P}.FPULockup-53804.patch"
+UNIPATCH_LIST="${DISTDIR}/${KV}.bz2 ${FILESDIR}/${P}.CAN-2004-0075.patch ${FILESDIR}/${P}.CAN-2004-0228.patch ${FILESDIR}/${P}.CAN-2004-0229.patch ${FILESDIR}/${P}.CAN-2004-0427.patch ${FILESDIR}/${P}.FPULockup-53804.patch ${FILESDIR}/${P}.IPTables-RDoS.patch"
K_PREPATCHED="yes"
UNIPATCH_STRICTORDER="yes"
diff --git a/sys-kernel/aa-sources/files/aa-sources-2.6.5.IPTables-RDoS.patch b/sys-kernel/aa-sources/files/aa-sources-2.6.5.IPTables-RDoS.patch
new file mode 100644
index 000000000000..8f89d1605c9a
--- /dev/null
+++ b/sys-kernel/aa-sources/files/aa-sources-2.6.5.IPTables-RDoS.patch
@@ -0,0 +1,11 @@
+--- net/ipv4/netfilter/ip_tables.c.orig 2004-04-04 05:36:47.000000000 +0200
++++ net/ipv4/netfilter/ip_tables.c 2004-06-24 21:24:26.000000000 +0200
+@@ -1461,7 +1461,7 @@
+ int *hotdrop)
+ {
+ /* tcp.doff is only 4 bits, ie. max 15 * 4 bytes */
+- char opt[60 - sizeof(struct tcphdr)];
++ u_int8_t opt[60 - sizeof(struct tcphdr)];
+ unsigned int i;
+
+ duprintf("tcp_match: finding option\n");