summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-14 05:13:06 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-14 05:13:06 +0000
commit765579381d7820f731d03d554e0041e4fbaea56c (patch)
tree8f7b70e2db70ecf4da7de63c03d6877e7edb129b /sys-kernel
parentFixed the patch name that was applied to the vanilla sources to provide the m... (diff)
downloadgentoo-2-765579381d7820f731d03d554e0041e4fbaea56c.tar.gz
gentoo-2-765579381d7820f731d03d554e0041e4fbaea56c.tar.bz2
gentoo-2-765579381d7820f731d03d554e0041e4fbaea56c.zip
I won
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/acpi-sources/acpi-sources-2.4.20-r9.ebuild37
-rw-r--r--sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r92
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-kernel/acpi-sources/acpi-sources-2.4.20-r9.ebuild b/sys-kernel/acpi-sources/acpi-sources-2.4.20-r9.ebuild
new file mode 100644
index 000000000000..d20375e41e06
--- /dev/null
+++ b/sys-kernel/acpi-sources/acpi-sources-2.4.20-r9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/acpi-sources/acpi-sources-2.4.20-r9.ebuild,v 1.1 2002/12/14 05:13:06 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.20"
+
+ACPI_PATCH="acpi-20021212-2.4.20.diff.gz"
+
+#add one of these in if this is for a pre or rc kernel
+#KERN_PATCH="patch-2.4.20-rc1.bz2"
+
+DESCRIPTION="Full sources for the latest ACPI Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://sourceforge/acpi/${ACPI_PATCH}"
+#http://www.kernel.org/pub/linux/kernel/v2.4/testing/${KERN_PATCH}
+
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+# bzcat ${DISTDIR}/${KERN_PATCH}|patch -p1 || die "-marcelo patch failed"
+ zcat ${DISTDIR}/${ACPI_PATCH}|patch -p1 || die "-acpi patch failed"
+
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r9 b/sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r9
new file mode 100644
index 000000000000..8d9a79e042f2
--- /dev/null
+++ b/sys-kernel/acpi-sources/files/digest-acpi-sources-2.4.20-r9
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 1b0dc19e8830b8450fe381bde42d952a acpi-20021212-2.4.20.diff.gz 561418