summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2005-06-16 09:00:04 +0000
committerChristian Birchinger <joker@gentoo.org>2005-06-16 09:00:04 +0000
commitca784b20dedebf843837d72b6cedcc71d7770035 (patch)
tree5dcabb3449e1c7e996a840aa6455bebc95f2c00d /sys-kernel
parentFix init.d script. (diff)
downloadgentoo-2-ca784b20dedebf843837d72b6cedcc71d7770035.tar.gz
gentoo-2-ca784b20dedebf843837d72b6cedcc71d7770035.tar.bz2
gentoo-2-ca784b20dedebf843837d72b6cedcc71d7770035.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.312
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.31.ebuild37
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 3d84af06fd91..7bc83953c0f0 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.83 2005/04/22 13:12:18 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.84 2005/06/16 09:00:04 joker Exp $
+
+*sparc-sources-2.4.31 (16 Jun 2005)
+
+ 16 Jun 2005; Christian Birchinger <joker@gentoo.org>
+ +sparc-sources-2.4.31.ebuild:
+ Version bump.
22 Apr 2005; Christian Birchinger <joker@gentoo.org>
sparc-sources-2.4.30.ebuild:
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31
new file mode 100644
index 000000000000..b574d2bae9f2
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31
@@ -0,0 +1,2 @@
+MD5 bf6e3843ca122e3ad9ad28b94f4b8ed5 linux-2.4.31.tar.bz2 31129841
+MD5 e990263e4f745f4bd86b3f8702b481c5 patches-2.4.31-sparc.tar.bz2 181416
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.31.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.31.ebuild
new file mode 100644
index 000000000000..2c430638b479
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.31.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.31.ebuild,v 1.1 2005/06/16 09:00:04 joker Exp $
+
+ETYPE="sources"
+IUSE="livecd ultra1"
+inherit kernel-2
+detect_version
+
+PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
+
+SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
+
+KEYWORDS="-* ~sparc"
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2"
+SRC_URI="${KERNEL_URI} ${SSV_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
+
+pkg_setup() {
+ use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
+ use livecd || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 5000_sparc64-ramdisk64.patch"
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ if [ ! -r "/proc/openprom/name" -o "cat /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+
+}