summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-18 04:10:00 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-18 04:10:00 +0000
commitce45cb7650f05351e981ed111f6d4fdb5c337c85 (patch)
tree0da132f552a90a186de0519b85f284d3d4d67044 /sys-kernel
parentVersion 2.01alpha3 (diff)
downloadgentoo-2-ce45cb7650f05351e981ed111f6d4fdb5c337c85.tar.gz
gentoo-2-ce45cb7650f05351e981ed111f6d4fdb5c337c85.tar.bz2
gentoo-2-ce45cb7650f05351e981ed111f6d4fdb5c337c85.zip
bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.62.ebuild105
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.621
2 files changed, 106 insertions, 0 deletions
diff --git a/sys-kernel/development-sources/development-sources-2.5.62.ebuild b/sys-kernel/development-sources/development-sources-2.5.62.ebuild
new file mode 100644
index 000000000000..08f98e97b5b5
--- /dev/null
+++ b/sys-kernel/development-sources/development-sources-2.5.62.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.62.ebuild,v 1.1 2003/02/18 04:10:00 lostlogic Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+if [ "${PR}" != "r0" ]; then
+ PATCH_URI="http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.5/${PV}/${PVR/r/mm}/${PVR/r/mm}.gz"
+fi
+KV=${PVR/r/mm}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# beta 2.5.59 kernel sources with the -mm1 patch.
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2 ${PATCH_URI}"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="x86 ppc"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl
+ sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ if [ "${PATCH_URI}" ]; then
+ mv linux-${OKV} linux-${KV}
+ cd ${S}
+ zcat ${DISTDIR}/${PVR/r/mm}.gz | patch -p1 -l || \
+ die "akpm patch application failure"
+ sed -e "s:^EXTRAVERSION.*$:EXTRAVERSION = -${PR/r/mm}:" \
+ Makefile > Makefile.new
+ mv Makefile.new Makefile
+ else
+ cd ${S}
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+}
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.62 b/sys-kernel/development-sources/files/digest-development-sources-2.5.62
new file mode 100644
index 000000000000..f5866e0b61f8
--- /dev/null
+++ b/sys-kernel/development-sources/files/digest-development-sources-2.5.62
@@ -0,0 +1 @@
+MD5 0ecd08b94b3bb398e3ec8368aa187a87 linux-2.5.62.tar.bz2 31727429