summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-08 02:40:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-08 02:40:54 +0000
commit35ff75a444656b389b18af6a513cce684d84bece (patch)
tree855cec801e966ab14644bbac2d1564dad1fc7d1b /sys-libs/db/db-1.85-r3.ebuild
parentadd detection for tar files (diff)
downloadgentoo-2-35ff75a444656b389b18af6a513cce684d84bece.tar.gz
gentoo-2-35ff75a444656b389b18af6a513cce684d84bece.tar.bz2
gentoo-2-35ff75a444656b389b18af6a513cce684d84bece.zip
Further cleanup the patch from Redhat, add a SONAME fix for alpha #48616, and tweak how we build/install.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-libs/db/db-1.85-r3.ebuild')
-rw-r--r--sys-libs/db/db-1.85-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-libs/db/db-1.85-r3.ebuild b/sys-libs/db/db-1.85-r3.ebuild
new file mode 100644
index 000000000000..c523954b9f24
--- /dev/null
+++ b/sys-libs/db/db-1.85-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r3.ebuild,v 1.1 2005/11/08 02:40:54 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="old berk db kept around for really old packages"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="ftp://ftp.sleepycat.com/releases/db.${PV}.tar.gz
+ mirror://gentoo/${PF}.patch.bz2"
+
+LICENSE="DB"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/db.${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PF}.patch
+ epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ sed -i -e "s:@GENTOO_LIBDIR@:$(get_libdir):" PORT/linux/Makefile || die
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+ emake -C PORT/linux OORG="${CFLAGS}" || die
+}
+
+src_install() {
+ make -C PORT/linux install DESTDIR="${D}" || die
+
+ # binary compat symlink
+ dosym libdb1.so.2 /usr/$(get_libdir)/libdb.so.2 || die
+
+ dosed "s:<db.h>:<db1/db.h>:" /usr/include/db1/ndbm.h
+ dosym db1/ndbm.h /usr/include/ndbm.h
+
+ dodoc changelog README
+ newdoc hash/README README.hash
+ docinto ps
+ dodoc docs/*.ps
+}