summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-15 01:48:51 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-15 01:48:51 +0000
commit8ddedae07be13683a4a15fbcee58888f5cbe0b3a (patch)
tree5f77443138e02461c4087791ce84b6c44223096d /sys-libs/glibc/glibc-2.3.6-r1.ebuild
parentuse _E_CROSS_HEADERS_ONLY in USE rather than as an env var (diff)
downloadgentoo-2-8ddedae07be13683a4a15fbcee58888f5cbe0b3a.tar.gz
gentoo-2-8ddedae07be13683a4a15fbcee58888f5cbe0b3a.tar.bz2
gentoo-2-8ddedae07be13683a4a15fbcee58888f5cbe0b3a.zip
use _E_CROSS_HEADERS_ONLY in USE rather than as an env var
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.6-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index 38d0c31ffd1b..ca07155b50a9 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.16 2006/01/26 02:17:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.17 2006/03/15 01:48:51 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -67,8 +67,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
- [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
- is_crosscompile
+ is_crosscompile && has _E_CROSS_HEADERS_ONLY ${USE}
}
GLIBC_RELEASE_VER=$(get_version_component_range 1-3)