summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-11-10 04:07:21 +0000
committerMike Frysinger <vapier@gentoo.org>2007-11-10 04:07:21 +0000
commit2e7c414650348890c0fc3a9a19bc94fb2c6a1560 (patch)
treeb81066a7c5fbe3bd5fd9b84318b2aea4fd7c9744 /sys-libs/glibc
parentBump to 11.0, for internal testing only. DO NOT USE (diff)
downloadgentoo-2-2e7c414650348890c0fc3a9a19bc94fb2c6a1560.tar.gz
gentoo-2-2e7c414650348890c0fc3a9a19bc94fb2c6a1560.tar.bz2
gentoo-2-2e7c414650348890c0fc3a9a19bc94fb2c6a1560.zip
Add support for USE=vanilla.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/eblits/src_unpack.eblit8
-rw-r--r--sys-libs/glibc/glibc-2.6.1.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.7.ebuild4
4 files changed, 14 insertions, 8 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 13deea52efbc..2a679a76a5e0 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.561 2007/10/24 06:11:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.562 2007/11/10 04:07:20 vapier Exp $
+
+ 10 Nov 2007; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_unpack.eblit, glibc-2.6.1.ebuild, glibc-2.7.ebuild:
+ Add support for USE=vanilla.
24 Oct 2007; Mike Frysinger <vapier@gentoo.org> glibc-2.7.ebuild:
Fix building on hppa #196868 and add patch for gcc-4.2 + noinlining #196245.
diff --git a/sys-libs/glibc/files/eblits/src_unpack.eblit b/sys-libs/glibc/files/eblits/src_unpack.eblit
index 7d57d187f47f..67c3bdd1473f 100644
--- a/sys-libs/glibc/files/eblits/src_unpack.eblit
+++ b/sys-libs/glibc/files/eblits/src_unpack.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_unpack.eblit,v 1.2 2007/10/07 03:43:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_unpack.eblit,v 1.3 2007/11/10 04:07:21 vapier Exp $
check_kheader_version() {
local version=$(
@@ -67,7 +67,9 @@ toolchain-glibc_src_unpack() {
# pull out all the addons
local d
for d in extra/*/configure ; do
- mv "${d%/configure}" "${S}" || die "moving ${d}"
+ d=${d%/configure}
+ [[ -d ${S}/${d} ]] && die "${d} already exists in \${S}"
+ mv "${d}" "${S}" || die "moving ${d} failed"
done
fi
@@ -93,7 +95,7 @@ toolchain-glibc_src_unpack() {
unpack glibc-infopages-${INFOPAGE_VER}.tar.bz2
fi
- if [[ -n ${PATCH_VER} ]] ; then
+ if [[ -n ${PATCH_VER} ]] && ! use vanilla ; then
cd "${S}"
EPATCH_MULTI_MSG="Applying Gentoo Glibc Patchset ${PATCH_GLIBC_VER}-${PATCH_VER} ..." \
EPATCH_EXCLUDE=${GLIBC_PATCH_EXCLUDE} \
diff --git a/sys-libs/glibc/glibc-2.6.1.ebuild b/sys-libs/glibc/glibc-2.6.1.ebuild
index 6c3d756c5e0f..f8b260785a8d 100644
--- a/sys-libs/glibc/glibc-2.6.1.ebuild
+++ b/sys-libs/glibc/glibc-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.1.ebuild,v 1.13 2007/10/24 03:24:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.1.ebuild,v 1.14 2007/11/10 04:07:20 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -26,7 +26,7 @@ NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.9"} # min kernel version nptl require
[[ ${CTARGET} == hppa* ]] && NPTL_KERN_VER=${NPTL_KERN_VER:-2.6.20}
-IUSE="debug nls hardened multilib selinux glibc-omitfp profile glibc-compat20 ${LT_VER:+nptl nptlonly}"
+IUSE="debug nls hardened multilib selinux glibc-omitfp profile glibc-compat20 vanilla ${LT_VER:+nptl nptlonly}"
S=${WORKDIR}/glibc-${RELEASE_VER}
# Here's how the cross-compile logic breaks down ...
diff --git a/sys-libs/glibc/glibc-2.7.ebuild b/sys-libs/glibc/glibc-2.7.ebuild
index 53ad1452fce4..ad9a25e09ff8 100644
--- a/sys-libs/glibc/glibc-2.7.ebuild
+++ b/sys-libs/glibc/glibc-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.7.ebuild,v 1.5 2007/11/07 05:37:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.7.ebuild,v 1.6 2007/11/10 04:07:20 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -26,7 +26,7 @@ NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.9"} # min kernel version nptl require
[[ ${CTARGET} == hppa* ]] && NPTL_KERN_VER=${NPTL_KERN_VER:-2.6.20}
-IUSE="debug nls hardened multilib selinux glibc-omitfp profile glibc-compat20 ${LT_VER:+nptl nptlonly}"
+IUSE="debug glibc-omitfp glibc-compat20 hardened multilib nls selinux profile vanilla ${LT_VER:+nptl nptlonly}"
S=${WORKDIR}/glibc-${RELEASE_VER}
# Here's how the cross-compile logic breaks down ...