summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-11 04:37:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-11 04:37:24 +0000
commit662c391eb72d324c101e5c0d63a740f78e283dba (patch)
tree8999da495dfccdd81579158fdb1d7b8af24c5e5f /sys-libs/glibc
parentVersion bump. (diff)
downloadgentoo-2-662c391eb72d324c101e5c0d63a740f78e283dba.tar.gz
gentoo-2-662c391eb72d324c101e5c0d63a740f78e283dba.tar.bz2
gentoo-2-662c391eb72d324c101e5c0d63a740f78e283dba.zip
Add missing popd by Sunil #95736.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild9
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild9
7 files changed, 37 insertions, 25 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 031593d0a9d8..2c8e94910e66 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.348 2005/06/07 01:38:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.349 2005/06/11 04:37:24 vapier Exp $
+
+ 11 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ glibc-2.3.4.20041102.ebuild, glibc-2.3.4.20041102-r1.ebuild,
+ glibc-2.3.4.20050125.ebuild, glibc-2.3.4.20050125-r1.ebuild,
+ glibc-2.3.5.ebuild, glibc-2.3.5.20050421.ebuild:
+ Add missing popd by Sunil #95736.
07 Jun 2005; Mike Frysinger <vapier@gentoo.org> files/2.3.5/ssp.c,
+files/2.3.5/glibc-2.3.5-propolice-guard-functions.patch,
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index 5498ac74d75b..de8649efba4c 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.14 2005/06/05 08:55:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.15 2005/06/11 04:37:24 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -894,13 +894,14 @@ src_install() {
mkdir -p ${D}/nptl ${D}/usr/include/nptl
make install_root=${D}/nptl install-headers PARALLELMFLAGS="${MAKEOPTS}"
pushd ${D}/nptl/usr/include > /dev/null
- for i in `find . -type f`; do
- if ! [ -f ${D}/usr/include/$i ] \
- || ! cmp -s $i ${D}/usr/include/$i; then
+ for i in `find . -type f`; do
+ if ! [ -f ${D}/usr/include/$i ] \
+ || ! cmp -s $i ${D}/usr/include/$i; then
mkdir -p ${D}/usr/include/nptl/`dirname $i`
cp -a $i ${D}/usr/include/nptl/$i
fi
done
+ popd > /dev/null
rm -rf ${D}/nptl
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index 6a0c06fd8339..355da06617d6 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.54 2005/06/05 08:55:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.55 2005/06/11 04:37:24 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -885,13 +885,14 @@ src_install() {
mkdir -p ${D}/nptl ${D}/usr/include/nptl
make install_root=${D}/nptl install-headers PARALLELMFLAGS="${MAKEOPTS}"
pushd ${D}/nptl/usr/include > /dev/null
- for i in `find . -type f`; do
- if ! [ -f ${D}/usr/include/$i ] \
- || ! cmp -s $i ${D}/usr/include/$i; then
+ for i in `find . -type f`; do
+ if ! [ -f ${D}/usr/include/$i ] \
+ || ! cmp -s $i ${D}/usr/include/$i; then
mkdir -p ${D}/usr/include/nptl/`dirname $i`
cp -a $i ${D}/usr/include/nptl/$i
fi
done
+ popd > /dev/null
rm -rf ${D}/nptl
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 6578d3c5482d..d3715077f3cf 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.49 2005/05/17 22:33:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.50 2005/06/11 04:37:24 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -377,13 +377,14 @@ toolchain-glibc_src_install() {
mkdir -p ${D}/nptl ${D}$(alt_headers)/nptl
make install_root=${D}/nptl install-headers PARALLELMFLAGS="${MAKEOPTS} -j1"
pushd ${D}/nptl/$(alt_headers) > /dev/null
- for i in `find . -type f`; do
- if ! [ -f ${D}$(alt_headers)/$i ] \
- || ! cmp -s $i ${D}$(alt_headers)/$i; then
+ for i in `find . -type f`; do
+ if ! [ -f ${D}$(alt_headers)/$i ] \
+ || ! cmp -s $i ${D}$(alt_headers)/$i; then
mkdir -p ${D}$(alt_headers)/nptl/`dirname $i`
cp -a $i ${D}$(alt_headers)/nptl/$i
fi
done
+ popd > /dev/null
rm -rf ${D}/nptl
fi
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125.ebuild
index 2d4e8b6aa7c9..fd5d09c17d00 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125.ebuild,v 1.41 2005/05/17 22:33:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125.ebuild,v 1.42 2005/06/11 04:37:24 vapier Exp $
KEYWORDS="~amd64 ~mips ~sparc ~x86 -ppc"
@@ -333,13 +333,14 @@ toolchain-glibc_src_install() {
mkdir -p ${D}/nptl ${D}$(alt_headers)/nptl
make install_root=${D}/nptl install-headers PARALLELMFLAGS="${MAKEOPTS}"
pushd ${D}/nptl/$(alt_headers) > /dev/null
- for i in `find . -type f`; do
- if ! [ -f ${D}$(alt_headers)/$i ] \
- || ! cmp -s $i ${D}$(alt_headers)/$i; then
+ for i in `find . -type f`; do
+ if ! [ -f ${D}$(alt_headers)/$i ] \
+ || ! cmp -s $i ${D}$(alt_headers)/$i; then
mkdir -p ${D}$(alt_headers)/nptl/`dirname $i`
cp -a $i ${D}$(alt_headers)/nptl/$i
fi
done
+ popd > /dev/null
rm -rf ${D}/nptl
fi
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index dc82ec1a9726..f650ee7cf57e 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.15 2005/06/06 05:09:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.16 2005/06/11 04:37:24 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -378,13 +378,14 @@ toolchain-glibc_src_install() {
mkdir -p ${D}/nptl ${D}$(alt_headers)/nptl
make install_root=${D}/nptl install-headers PARALLELMFLAGS="${MAKEOPTS} -j1"
pushd ${D}/nptl/$(alt_headers) > /dev/null
- for i in `find . -type f`; do
- if ! [ -f ${D}$(alt_headers)/$i ] \
- || ! cmp -s $i ${D}$(alt_headers)/$i; then
+ for i in `find . -type f`; do
+ if ! [ -f ${D}$(alt_headers)/$i ] \
+ || ! cmp -s $i ${D}$(alt_headers)/$i; then
mkdir -p ${D}$(alt_headers)/nptl/`dirname $i`
cp -a $i ${D}$(alt_headers)/nptl/$i
fi
done
+ popd > /dev/null
rm -rf ${D}/nptl
fi
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index 962d5eed753e..5a19ef5088b1 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.24 2005/06/07 01:38:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.25 2005/06/11 04:37:24 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -377,13 +377,14 @@ toolchain-glibc_src_install() {
mkdir -p ${D}/nptl ${D}$(alt_headers)/nptl
make install_root=${D}/nptl install-headers PARALLELMFLAGS="${MAKEOPTS} -j1"
pushd ${D}/nptl/$(alt_headers) > /dev/null
- for i in `find . -type f`; do
- if ! [ -f ${D}$(alt_headers)/$i ] \
- || ! cmp -s $i ${D}$(alt_headers)/$i; then
+ for i in `find . -type f`; do
+ if ! [ -f ${D}$(alt_headers)/$i ] \
+ || ! cmp -s $i ${D}$(alt_headers)/$i; then
mkdir -p ${D}$(alt_headers)/nptl/`dirname $i`
cp -a $i ${D}$(alt_headers)/nptl/$i
fi
done
+ popd > /dev/null
rm -rf ${D}/nptl
fi