summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-01-14 10:43:40 +0000
committerHanno Böck <hanno@gentoo.org>2005-01-14 10:43:40 +0000
commit3e785b761f662299d3b8da2b7f548c319d0ba6be (patch)
tree724817ff27e754921cc7371f966527592c0a3b34 /sys-libs/gwenhywfar
parentFixed broken Manifest. (diff)
downloadgentoo-2-3e785b761f662299d3b8da2b7f548c319d0ba6be.tar.gz
gentoo-2-3e785b761f662299d3b8da2b7f548c319d0ba6be.tar.bz2
gentoo-2-3e785b761f662299d3b8da2b7f548c319d0ba6be.zip
gwenhywfar bump
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.4.11
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.4.1.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index e1e06cf07dea..bb3f663aafa7 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.5 2005/01/05 11:58:56 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.6 2005/01/14 10:43:40 hanno Exp $
+
+*gwenhywfar-1.4.1 (14 Jan 2005)
+
+ 14 Jan 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.4.1.ebuild:
+ Version bump.
*gwenhywfar-1.4 (05 Jan 2005)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.4.1 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.4.1
new file mode 100644
index 000000000000..87b64bbba712
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.4.1
@@ -0,0 +1 @@
+MD5 63af6de9bed27debd675ee707ffa9442 gwenhywfar-1.4.1.tar.gz 969515
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.4.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.4.1.ebuild
new file mode 100644
index 000000000000..77ed8fbdddcc
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.4.1.ebuild,v 1.1 2005/01/14 10:43:40 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~alpha ~ppc"
+
+IUSE="debug ssl doc"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}