summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-11-28 23:46:58 +0000
committerHanno Böck <hanno@gentoo.org>2005-11-28 23:46:58 +0000
commit6b49336e12a35c0f04593627b5591e11e2a40ee9 (patch)
tree06e78c39ad211e4093e2ce8f846e9edc68b0c8b6 /sys-libs/gwenhywfar
parentktoblzcheck version bump and gcc41 fix (diff)
downloadgentoo-2-6b49336e12a35c0f04593627b5591e11e2a40ee9.tar.gz
gentoo-2-6b49336e12a35c0f04593627b5591e11e2a40ee9.tar.bz2
gentoo-2-6b49336e12a35c0f04593627b5591e11e2a40ee9.zip
gwenhywfar version bump
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog8
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.0_beta1
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.99.0_beta.ebuild42
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index cd19bdb47997..f3652fff8c16 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.19 2005/11/26 11:47:14 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.20 2005/11/28 23:46:58 hanno Exp $
+
+*gwenhywfar-1.99.0_beta (28 Nov 2005)
+
+ 28 Nov 2005; Hanno Boeck <hanno@gentoo.org>
+ +gwenhywfar-1.99.0_beta.ebuild:
+ Version bump.
26 Nov 2005; Simon Stelling <blubb@gentoo.org> gwenhywfar-1.18.0.ebuild:
mark stable on amd64
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.0_beta b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.0_beta
new file mode 100644
index 000000000000..71ff5a871d9b
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.0_beta
@@ -0,0 +1 @@
+MD5 d2121a78b2fe12a16f8cbee65993710c gwenhywfar-1.99.0beta.tar.gz 1109645
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.99.0_beta.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.99.0_beta.ebuild
new file mode 100644
index 000000000000..2d0a162ea613
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.99.0_beta.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.99.0_beta.ebuild,v 1.1 2005/11/28 23:46:58 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+S=${WORKDIR}/${P/_/}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ `use_enable ncurses gwenui` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}