summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2012-10-09 20:00:12 +0000
committerSven Vermeulen <swift@gentoo.org>2012-10-09 20:00:12 +0000
commitc68c1aca56492f8a4a90072ac45278c60af5b94f (patch)
tree74d6b328c0def92d764ee8b3169cd615580f71f9 /sys-libs/libselinux/files
parentNew upstream SELinux utilities release (diff)
downloadgentoo-2-c68c1aca56492f8a4a90072ac45278c60af5b94f.tar.gz
gentoo-2-c68c1aca56492f8a4a90072ac45278c60af5b94f.tar.bz2
gentoo-2-c68c1aca56492f8a4a90072ac45278c60af5b94f.zip
New upstream SELinux utilities release
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libselinux/files')
-rw-r--r--sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch22
-rw-r--r--sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch12
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch b/sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch
new file mode 100644
index 000000000000..625ccfb60804
--- /dev/null
+++ b/sys-libs/libselinux/files/libselinux-2.1.12-mountsys.patch
@@ -0,0 +1,22 @@
+diff -ur libselinux-2.1.12.orig/src/load_policy.c libselinux-2.1.12/src/load_policy.c
+--- libselinux-2.1.12.orig/src/load_policy.c 2012-09-29 09:32:18.374170451 +0200
++++ libselinux-2.1.12/src/load_policy.c 2012-09-29 09:34:05.130172917 +0200
+@@ -370,8 +370,16 @@
+ * mount it if present for use in the calls below.
+ */
+ const char *mntpoint = NULL;
+- if (mount(SELINUXFS, SELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
+- mntpoint = SELINUXMNT;
++ /* First make sure /sys is mounted */
++ if (mount("sysfs", "/sys", "sysfs", 0, 0) == 0 || errno == EBUSY) {
++ if (mount(SELINUXFS, SELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
++ mntpoint = SELINUXMNT;
++ } else {
++ /* check old mountpoint */
++ if (mount(SELINUXFS, OLDSELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
++ mntpoint = OLDSELINUXMNT;
++ }
++ }
+ } else {
+ /* check old mountpoint */
+ if (mount(SELINUXFS, OLDSELINUXMNT, SELINUXFS, 0, 0) == 0 || errno == EBUSY) {
diff --git a/sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch b/sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch
new file mode 100644
index 000000000000..02ee2b39bc7f
--- /dev/null
+++ b/sys-libs/libselinux/files/libselinux-2.1.9-support_ruby19.patch
@@ -0,0 +1,12 @@
+diff -ur libselinux-2.1.9.orig/src/Makefile libselinux-2.1.9/src/Makefile
+--- libselinux-2.1.9.orig/src/Makefile 2012-10-06 21:11:43.140757973 +0200
++++ libselinux-2.1.9/src/Makefile 2012-10-06 21:12:54.896758126 +0200
+@@ -15,7 +15,7 @@
+ PYLIBDIR ?= $(LIBDIR)/$(PYLIBVER)
+ RUBYLIBVER ?= $(shell ruby -e 'print RUBY_VERSION.split(".")[0..1].join(".")')
+ RUBYPLATFORM ?= $(shell ruby -e 'print RUBY_PLATFORM')
+-RUBYINC ?= $(LIBDIR)/ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
++RUBYINC ?= $(shell pkg-config --cflags ruby-$(RUBYLIBVER))
+ RUBYINSTALL ?= $(LIBDIR)/ruby/site_ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
+ LIBBASE=$(shell basename $(LIBDIR))
+