summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-10 00:53:24 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-10 00:53:24 +0000
commit82f224597843ffc660ebfac1a79e7513e03bf751 (patch)
tree3fd6ca71d275a8c3005f0ade11949c94350fed25 /sys-libs/readline
parentNew ebuild for mate-extra/mate-sensors-applet, MATE panel applet to display r... (diff)
downloadgentoo-2-82f224597843ffc660ebfac1a79e7513e03bf751.tar.gz
gentoo-2-82f224597843ffc660ebfac1a79e7513e03bf751.tar.bz2
gentoo-2-82f224597843ffc660ebfac1a79e7513e03bf751.zip
Force some cross-compile tests to the right answer #503312 by Hristo Venev. Add fix from upstream for vi mode.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog10
-rw-r--r--sys-libs/readline/files/readline-6.3-vi-last.patch19
-rw-r--r--sys-libs/readline/readline-6.3-r1.ebuild (renamed from sys-libs/readline/readline-6.3.ebuild)14
3 files changed, 40 insertions, 3 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index ea93539890bc..97185f2480ac 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.194 2014/02/28 22:29:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.195 2014/03/10 00:53:24 vapier Exp $
+
+*readline-6.3-r1 (10 Mar 2014)
+
+ 10 Mar 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/readline-6.3-vi-last.patch, +readline-6.3-r1.ebuild,
+ -readline-6.3.ebuild:
+ Force some cross-compile tests to the right answer #503312 by Hristo Venev.
+ Add fix from upstream for vi mode.
28 Feb 2014; Mike Frysinger <vapier@gentoo.org> readline-6.3.ebuild:
Unmask for all.
diff --git a/sys-libs/readline/files/readline-6.3-vi-last.patch b/sys-libs/readline/files/readline-6.3-vi-last.patch
new file mode 100644
index 000000000000..2a0b0cddc281
--- /dev/null
+++ b/sys-libs/readline/files/readline-6.3-vi-last.patch
@@ -0,0 +1,19 @@
+fix from upstream
+
+https://lists.gnu.org/archive/html/bug-readline/2014-03/msg00015.html
+
+*** ../bash-4.3/lib/readline/readline.c 2013-10-28 14:58:06.000000000 -0400
+--- lib/readline/readline.c 2014-03-07 15:20:33.000000000 -0500
+***************
+*** 965,969 ****
+ if (rl_editing_mode == vi_mode && _rl_keymap == vi_movement_keymap &&
+ key != ANYOTHERKEY &&
+! rl_key_sequence_length == 1 && /* XXX */
+ _rl_vi_textmod_command (key))
+ _rl_vi_set_last (key, rl_numeric_arg, rl_arg_sign);
+--- 965,969 ----
+ if (rl_editing_mode == vi_mode && _rl_keymap == vi_movement_keymap &&
+ key != ANYOTHERKEY &&
+! _rl_dispatching_keymap == vi_movement_keymap &&
+ _rl_vi_textmod_command (key))
+ _rl_vi_set_last (key, rl_numeric_arg, rl_arg_sign);
diff --git a/sys-libs/readline/readline-6.3.ebuild b/sys-libs/readline/readline-6.3-r1.ebuild
index 5e47f6fd9e82..627d15dfc7be 100644
--- a/sys-libs/readline/readline-6.3.ebuild
+++ b/sys-libs/readline/readline-6.3-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.3.ebuild,v 1.2 2014/02/28 22:29:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.3-r1.ebuild,v 1.1 2014/03/10 00:53:24 vapier Exp $
EAPI=4
inherit eutils multilib toolchain-funcs flag-o-matic multilib-minimal
# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.2-patches/
+# See ftp://ftp.cwru.edu/pub/bash/readline-6.3-patches/
PLEVEL=${PV##*_p}
MY_PV=${PV/_p*}
MY_PV=${MY_PV/_/-}
@@ -55,6 +55,7 @@ src_prepare() {
[[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
epatch "${FILESDIR}"/${PN}-6.2-rlfe-tgoto.patch #385091
+ epatch "${FILESDIR}"/${PN}-6.3-vi-last.patch
# Force ncurses linking. #71420
# Use pkg-config to get the right values. #457558
@@ -85,6 +86,15 @@ src_configure() {
# Force the test since we used sed above to force it.
export bash_cv_termcap_lib=ncurses
+ # Control cross-compiling cases when we know the right answer.
+ # In cases where the C library doesn't support wide characters, readline
+ # itself won't work correctly, so forcing the answer below should be OK.
+ if tc-is-cross-compiler ; then
+ export bash_cv_func_sigsetjmp='present'
+ export bash_cv_func_ctype_nonascii='yes'
+ export bash_cv_wcwidth_broken='no' #503312
+ fi
+
# This is for rlfe, but we need to make sure LDFLAGS doesn't change
# so we can re-use the config cache file between the two.
append-ldflags -L.