summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-02 20:20:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-02 20:20:41 +0000
commit9c76aecf792dd15b55ba207eb986eefc7fa9696a (patch)
tree737b01239122037248211414196c8bafa34984fa /sys-libs/slang
parentMarking tk-8.5.10 ppc64 for bug 406607 (diff)
downloadgentoo-2-9c76aecf792dd15b55ba207eb986eefc7fa9696a.tar.gz
gentoo-2-9c76aecf792dd15b55ba207eb986eefc7fa9696a.tar.bz2
gentoo-2-9c76aecf792dd15b55ba207eb986eefc7fa9696a.zip
old
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog6
-rw-r--r--sys-libs/slang/files/slang-2.1.2-slsh-libs.patch12
-rw-r--r--sys-libs/slang/slang-2.2.2.ebuild65
-rw-r--r--sys-libs/slang/slang-2.2.3.ebuild61
4 files changed, 5 insertions, 139 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index fe5832900cde..18ab63207c7d 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/slang
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.128 2012/03/02 20:19:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.129 2012/03/02 20:20:40 ssuominen Exp $
+
+ 02 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ -files/slang-2.1.2-slsh-libs.patch, -slang-2.2.2.ebuild, -slang-2.2.3.ebuild:
+ old
02 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> slang-2.2.4.ebuild:
ppc64 stable wrt #397239
diff --git a/sys-libs/slang/files/slang-2.1.2-slsh-libs.patch b/sys-libs/slang/files/slang-2.1.2-slsh-libs.patch
deleted file mode 100644
index da9c3ecfaa09..000000000000
--- a/sys-libs/slang/files/slang-2.1.2-slsh-libs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur slang-2.1.2.orig/slsh/Makefile.in slang-2.1.2/slsh/Makefile.in
---- slang-2.1.2.orig/slsh/Makefile.in 2007-09-09 10:39:18.000000000 +0900
-+++ slang-2.1.2/slsh/Makefile.in 2007-09-19 01:31:41.000000000 +0900
-@@ -74,7 +74,7 @@
- slsh_exe: slsh.o readline.o
- $(CC) $(CFLAGS) slsh.o readline.o -o slsh_exe $(LDFLAGS) $(SRC_LIBS)
- slsh: slsh.o readline.o
-- $(CC) $(CFLAGS) slsh.o readline.o -o slsh $(LDFLAGS) $(INST_LIBS)
-+ $(CC) $(CFLAGS) slsh.o readline.o -o slsh $(LDFLAGS) $(SRC_LIBS)
- slsh.o: slsh.c slsh.h config.h Makefile
- $(CC) -c $(CFLAGS) $(SLANG_SRCINC) $(DEFS) slsh.c
- readline.o: readline.c slsh.h config.h Makefile
diff --git a/sys-libs/slang/slang-2.2.2.ebuild b/sys-libs/slang/slang-2.2.2.ebuild
deleted file mode 100644
index a3473f3e6630..000000000000
--- a/sys-libs/slang/slang-2.2.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.2.ebuild,v 1.9 2010/12/27 12:51:44 ssuominen Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="A portable programmer's library designed to allow a developer to create robust portable software"
-HOMEPAGE="http://www.jedsoft.org/slang/"
-SRC_URI="mirror://slang/v${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="cjk pcre png readline zlib"
-
-RDEPEND="sys-libs/ncurses
- pcre? ( dev-libs/libpcre )
- png? ( media-libs/libpng )
- cjk? ( dev-libs/oniguruma )
- readline? ( sys-libs/readline )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.1.2-slsh-libs.patch \
- "${FILESDIR}"/${PN}-2.1.3-uclibc.patch
-
- sed -i \
- -e '/^TERMCAP=/s:=.*:=:' \
- configure || die
-}
-
-src_configure() {
- local myconf
-
- if use readline; then
- myconf+=" --with-readline=gnu"
- else
- myconf+=" --with-readline=slang"
- fi
-
- econf \
- $(use_with cjk onig) \
- $(use_with pcre) \
- $(use_with png) \
- $(use_with zlib z) \
- ${myconf}
-}
-
-src_compile() {
- emake -j1 elf static || die "emake elf static failed"
-
- cd slsh
- emake -j1 slsh || die "emake slsh failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install-all || die "emake install-all failed"
-
- rm -rf "${D}"/usr/share/doc/{slang,slsh}
-
- dodoc NEWS README *.txt doc/{,internal,text}/*.txt
- dohtml doc/slangdoc.html slsh/doc/html/*.html
-}
diff --git a/sys-libs/slang/slang-2.2.3.ebuild b/sys-libs/slang/slang-2.2.3.ebuild
deleted file mode 100644
index f5a03db4647c..000000000000
--- a/sys-libs/slang/slang-2.2.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.3.ebuild,v 1.1 2010/12/27 12:51:44 ssuominen Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="A multi-platform programmer's library designed to allow a developer to create robust software"
-HOMEPAGE="http://www.jedsoft.org/slang/"
-SRC_URI="mirror://slang/v${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="cjk pcre png readline zlib"
-
-# ncurses for ncurses5-config to get terminfo directory
-RDEPEND="sys-libs/ncurses
- pcre? ( dev-libs/libpcre )
- png? ( >=media-libs/libpng-1.4 )
- cjk? ( dev-libs/oniguruma )
- readline? ( sys-libs/readline )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.2.3-slsh-libs.patch
-
- # avoid linking to -ltermcap race with some systems
- sed -i -e '/^TERMCAP=/s:=.*:=:' configure || die
-}
-
-src_configure() {
- local myconf=slang
- use readline && myconf=gnu
-
- econf \
- --with-readline=${myconf} \
- $(use_with pcre) \
- $(use_with cjk onig) \
- $(use_with png) \
- $(use_with zlib z)
-}
-
-src_compile() {
- emake elf static || die
-
- cd slsh
- emake slsh || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install-all || die
-
- rm -rf "${D}"/usr/share/doc/{slang,slsh}
-
- dodoc NEWS README *.txt doc/{,internal,text}/*.txt
- dohtml doc/slangdoc.html slsh/doc/html/*.html
-}