summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-02-12 11:43:28 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-02-12 11:43:28 +0000
commita41ccd177853720bb1191b1e14a118eb20802366 (patch)
tree40d3e3276ee728bbb6d0933b89b918b709a7cc08 /sys-libs/tevent
parentMask more packages for removal. (diff)
downloadgentoo-2-a41ccd177853720bb1191b1e14a118eb20802366.tar.gz
gentoo-2-a41ccd177853720bb1191b1e14a118eb20802366.tar.bz2
gentoo-2-a41ccd177853720bb1191b1e14a118eb20802366.zip
Bump to 0.9.15, bug 403237. Fix bug 403239 for 0.9.15
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/ChangeLog10
-rw-r--r--sys-libs/tevent/files/add-py-file.patch32
-rw-r--r--sys-libs/tevent/tevent-0.9.15.ebuild45
3 files changed, 85 insertions, 2 deletions
diff --git a/sys-libs/tevent/ChangeLog b/sys-libs/tevent/ChangeLog
index ffbca7056066..7115c8b8a279 100644
--- a/sys-libs/tevent/ChangeLog
+++ b/sys-libs/tevent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/tevent
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.9 2011/10/31 16:02:11 vostorga Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.10 2012/02/12 11:43:28 maksbotan Exp $
+
+*tevent-0.9.15 (12 Feb 2012)
+
+ 12 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org> +files/add-py-file.patch,
+ +tevent-0.9.15.ebuild:
+ Bump to 0.9.15, bug 403237. Fix bug 403239 for 0.9.15
31 Oct 2011; Víctor Ostorga <vostorga@gentoo.org> tevent-0.9.14.ebuild:
Fixing file collision with sys-libs/talloc, bug #384873
diff --git a/sys-libs/tevent/files/add-py-file.patch b/sys-libs/tevent/files/add-py-file.patch
new file mode 100644
index 000000000000..cd919834e66d
--- /dev/null
+++ b/sys-libs/tevent/files/add-py-file.patch
@@ -0,0 +1,32 @@
+--- /dev/null
++++ b/tevent.py
+@@ -0,0 +1,29 @@
++#!/usr/bin/python
++#
++# Python integration for tevent
++#
++# Copyright (C) Jelmer Vernooij 2011
++#
++# ** NOTE! The following LGPL license applies to the tevent
++# ** library. This does NOT imply that all of Samba is released
++# ** under the LGPL
++#
++# This library is free software; you can redistribute it and/or
++# modify it under the terms of the GNU Lesser General Public
++# License as published by the Free Software Foundation; either
++# version 3 of the License, or (at your option) any later version.
++#
++# This library is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++# Lesser General Public License for more details.
++#
++# You should have received a copy of the GNU Lesser General Public
++# License along with this library; if not, see <http://www.gnu.org/licenses/>.
++
++from _tevent import (
++ __version__,
++ backend_list,
++ Context,
++ Signal,
++ )
diff --git a/sys-libs/tevent/tevent-0.9.15.ebuild b/sys-libs/tevent/tevent-0.9.15.ebuild
new file mode 100644
index 000000000000..4faba605ae8a
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.15.ebuild,v 1.1 2012/02/12 11:43:28 maksbotan Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit waf-utils python
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4.2
+ >=sys-libs/talloc-2.0.6[python]"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+PATCHES=( "${FILESDIR}"/add-py-file.patch )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ waf-utils_src_install
+ insinto $(python_get_sitedir)
+ doins tevent.py
+}
+
+pkg_postinst() {
+ python_mod_optimize tevent.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tevent.py
+}