summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-09-23 17:52:32 +0000
committerJustin Lecher <jlec@gentoo.org>2011-09-23 17:52:32 +0000
commit1f633727081d86f52cc7ee7f1e36955785bc3168 (patch)
tree57afe0c6907c364551390861f4f3ce701e767759 /sys-libs/zlib
parentVersion bump, EAPI4, fix install phase via patch instead of using helpers. Dr... (diff)
downloadgentoo-2-1f633727081d86f52cc7ee7f1e36955785bc3168.tar.gz
gentoo-2-1f633727081d86f52cc7ee7f1e36955785bc3168.tar.bz2
gentoo-2-1f633727081d86f52cc7ee7f1e36955785bc3168.zip
econf dies alone
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/ChangeLog6
-rw-r--r--sys-libs/zlib/metadata.xml8
-rw-r--r--sys-libs/zlib/zlib-1.2.5.1-r2.ebuild4
3 files changed, 11 insertions, 7 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index e40d59564d0a..1343cc6bda6e 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.96 2011/09/21 21:18:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.97 2011/09/23 17:52:32 jlec Exp $
+
+ 23 Sep 2011; Justin Lecher <jlec@gentoo.org> zlib-1.2.5.1-r2.ebuild,
+ metadata.xml:
+ econf dies alone
21 Sep 2011; Mike Frysinger <vapier@gentoo.org> zlib-1.2.5.1-r2.ebuild:
Also rename macros in new minizip headers.
diff --git a/sys-libs/zlib/metadata.xml b/sys-libs/zlib/metadata.xml
index cfdad4c916fd..600525ce128e 100644
--- a/sys-libs/zlib/metadata.xml
+++ b/sys-libs/zlib/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>base-system</herd>
-<use>
- <flag name='minizip'>include the minizip library for quick and dirty zip extraction</flag>
-</use>
+ <herd>base-system</herd>
+ <use>
+ <flag name="minizip">include the minizip library for quick and dirty zip extraction</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-libs/zlib/zlib-1.2.5.1-r2.ebuild b/sys-libs/zlib/zlib-1.2.5.1-r2.ebuild
index e01908921581..6a56710c51ac 100644
--- a/sys-libs/zlib/zlib-1.2.5.1-r2.ebuild
+++ b/sys-libs/zlib/zlib-1.2.5.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5.1-r2.ebuild,v 1.2 2011/09/21 21:18:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5.1-r2.ebuild,v 1.3 2011/09/23 17:52:32 jlec Exp $
inherit autotools eutils toolchain-funcs
@@ -57,7 +57,7 @@ src_compile() {
esac
if use minizip ; then
cd contrib/minizip
- econf $(use_enable static-libs static) || die
+ econf $(use_enable static-libs static)
emake || die
fi
}