summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-19 08:05:27 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-19 08:05:27 +0000
commit02d56286a122de19a832aec703f7910494127ab3 (patch)
tree335f5e976475012dc4d0ab99e70daca07d85ba39 /sys-libs
parent2.1_pre6-r4 regression fixes and feature release (diff)
downloadgentoo-2-02d56286a122de19a832aec703f7910494127ab3.tar.gz
gentoo-2-02d56286a122de19a832aec703f7910494127ab3.tar.bz2
gentoo-2-02d56286a122de19a832aec703f7910494127ab3.zip
Add misc source touchups by Beech Horn #126695.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pwdb/ChangeLog6
-rw-r--r--sys-libs/pwdb/files/pwdb-0.62-build.patch47
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-libs/pwdb/ChangeLog b/sys-libs/pwdb/ChangeLog
index ee1f6449eda7..6b44cdf64575 100644
--- a/sys-libs/pwdb/ChangeLog
+++ b/sys-libs/pwdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/pwdb
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.34 2006/02/12 21:53:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pwdb/ChangeLog,v 1.35 2006/03/19 08:05:26 vapier Exp $
+
+ 19 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ files/pwdb-0.62-build.patch:
+ Add misc source touchups by Beech Horn #126695.
12 Feb 2006; Mike Frysinger <vapier@gentoo.org> pwdb-0.62.ebuild:
Restrict broken src_test #122603 by Ryan Hill.
diff --git a/sys-libs/pwdb/files/pwdb-0.62-build.patch b/sys-libs/pwdb/files/pwdb-0.62-build.patch
index 4ed83a380ca9..5e91d96209e8 100644
--- a/sys-libs/pwdb/files/pwdb-0.62-build.patch
+++ b/sys-libs/pwdb/files/pwdb-0.62-build.patch
@@ -1,3 +1,9 @@
+ - drop ldconfig junk
+ - add missing headers
+ - add missing comma to supp_entry
+
+http://bugs.gentoo.org/126695
+
--- libpwdb/Makefile
+++ libpwdb/Makefile
@@ -69,7 +69,7 @@
@@ -9,3 +15,44 @@
ln -sf $(LIBFILENAME) $(LIBDIR)/$(LIBDYNAME)
$(INSTALL) -m 644 $(LIBSTATIC) $(LIBDIR)
+--- libpwdb/posix/pwd.c
++++ libpwdb/posix/pwd.c
+@@ -7,6 +7,7 @@
+ */
+
+ #include <stdio.h>
++#include <string.h>
+
+ #define PWDB_HARD_CORE 1
+ #include <pwdb/pwdb_public.h>
+--- libpwdb/posix/undefined.c
++++ libpwdb/posix/undefined.c
+@@ -5,6 +5,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #define PWDB_HARD_CORE 1
+ #include <pwdb/pwdb_public.h>
+--- libpwdb/pwdb/pwdb_helper.c
++++ libpwdb/pwdb/pwdb_helper.c
+@@ -18,6 +18,7 @@
+ *
+ */
+
++#include <string.h>
+ #include "pwdb_public.h"
+ #include "pwdb_module.h"
+
+--- libpwdb/pwdb/interface/shadow/group.c
++++ libpwdb/pwdb/interface/shadow/group.c
+@@ -533,7 +533,7 @@
+
+ static const char *supp_entry[] = {
+ "group", "passwd",
+- "users", "admins" /* these are from /etc/group */
++ "users", "admins", /* these are from /etc/group */
+ "groups", /* these are serviced by requests */
+ NULL
+ };